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1. DEVICE SETTINGS: Network\addressing 
 

1.1 Overview 
 

 
 
 
These new advanced settings have been added: 
 

timeout msec 
Auto-retry 
 

 
In typical applications these values must not be changed, as wrong settings may result in bad 
communication with the a single device or even with the entire network. 
 
Nevertheless, in special cases, these parameters must be properly set or adjusted to have the network of 
devices correctly working. 
 
If the user changed them, without knowing exactly what are they about, it is suggested to restore them to the 
default values shown above. 
 
 

1.2 Timeout 
 

 
It is the number of milliseconds RICS wait for the device to reply to a polling request, such as the reading of 
the probe values. The slowest the device, the higher the value must be.  



 

 
If the value is Default RICS automatically select a standard value, suitable for that device model. In many 
cases this is something about 200 ms. Settings values below 100 ms is highly unrecommended. 
Note that in normal circumstances lowest values will not result in a higher communication speed. 
 

 
 

1.3 Autoretry 
 

 
It is the number of times RICS automatically resend a polling request in case of transmission error or timeout 
error. 
 



 

    

2. DEVICE SETTINGS: Network\driver 
 
 

2.1 Overview 
 
The plug and play system for the Evco devices has been improved. 
RICS can now offer a better basic support for device models for which a specific device driver has not yet 
been included or installed in the RICS application itself. 
 
This may happen in these cases: 
 

� Newer or special firmware releases of the controller, which are not recognised by the RICS 
software version in use. Usually a RICS software upgrade can fix the problem, so the 
generic driver is just a useful temporary solution. 

� A programmable controller, provided with a custom application software, for which a specific 
RICS driver has not been developped by the application designer. 
 

When the proper standard driver is not available on the system, RICS can be configured to load an 
Alternate driver instead. Depending on the controller type, this is generally enough to check the fieldbus 
level is OK (wiring, protocol addressing, communication quality) and to identify the firmware revision of the 
controller and the needed driver name. 
 
For some specific families of controllers RICS provides alternate drivers that can also offer basic features, 
such as main sensors reading and storing or I/O status monitoring). In that case internal parameters or 
specific statuses are generally not available. 
 

2.2 Driver info button 
 

 
 
The new driver info button directly recalls the device info page.  The label on the button can be coloured in 
orange or red in case of not normal configuration (I.e. red if the device driver is missing, the device model is  
unknown etc).  
 

 
2.3 Disable write check box 

 
 

The Disable write   checkbox prevents any writing access to the device from the PC. Note that it is not 
possible to change the internal values of a device (i.e. parameters) if this option is checked. 
 
This is not only desirable but also necessary in case a general device driver is used instead of the 
standard one, to avoid a non perfectly compatible driver could lead to unwanted changes of internal 
programming of the controller. 
 
 

 



 

 

 
2.4 Alternate driver checkbox 

 
 

This check box (automatically checked when RICS first loads an alternate driver)  tells the software the 
driver  loaded must be considered NOT the standard one. This way the message 'Alternate driver' will be 
permanently shown in the device status, reminding the user that the standard driver still have to be installed 
on the system. 
If the check box is not checked and the driver file  is not empty it means that a custom device driver or an 
alternate driver has been forced to be used for the device, regardless if this is appropriate or not. 
See also Find driver 
 
 
 

2.5 Find driver button 
 

 
This button makes RICS find an alternate driver when needed. If the driver is already loaded it directly looks 
for upgrades on the internet. 
 

2.6 Vtp driver extentions 
 

 
These fields are available only for some kind of controllers and are intended for future use. Leave empty. 
 
 

3. DEVICE SETTINGS: Recorder 
 

3.1 Recorder 
 



 

 
The new tab On change has been added. 
 
Groupbox Probes: 

Record probes 

Smooth varations 
 
 

Now you can switch on or off the Variation recording feature for probes. 
 
When On change\Record probes is not checked RICS just sample the probes (I.e. 

temperature values read by the sensors connected to a device) according to the sampling 

interval of the device. 

When the option is checked, these values are stored also after a certain change of the value 

(see also Variation recording/Variation recording of the main probe), depending on the 

Smooth variations setting. 
 
If smooth variations is checked, probes are stored any time the value changes.  

This results in the most accurate data recording and reporting as well as in more storage 

memory occupation(Hard disk space). Handling a huge amount of data can also slow down the 

operating system and/or the report generation, depending on the PC hardware in use. 
 
If smooth variations is not checked RICS uses and internal algorithm to determine when a 

probe must be extra sampled, depending on the variation, the device type, the device status 

and the probe function. This way RICS is trying to balance the Hard disk space and the 

accuracy in reports. 
 
Note: The behaviour of RICS 4.21 is the same of RICS 4.30 with Record probes checked and Smooth 
variations not checked. 
 
 

3.2 RECORDER 
 
This field are available only for some kind of controllers and are intended for future use. Leave empty. 
 
 



 

 

4. DEVICE SETTINGS: Image 
 

4.1 Overview 
 
 
This page has been improved and it is now more user friendly.  
Some features have also been added. 

 
 

 

 
 

4.2 Label\Include Name 
 

In previous RICS version the device label always contained the device name.  
Now it is possible to prevent the device name from been shown in the main view. 
See also include status. 
 
 

4.3 Label\Include status 
 

It is now possible to include the device status in the device label. 
Note:If both  Include Name and Include status are checked then a two line label is shown. In this case 
the vertical label position might require to be adjusted. 
 

 

4.4 Image\style 
 

New images style has been added, included the No picture style. 



 

 

 



 

 

5. DEVICE SETTINGS: Alarms 
 

5.1 Show originated on PC 
 
 
This checkbox unchecked hides the pages related to alarms generated on the PC (thresholds, digital inputs). 
 

 



 

 

6. MESSENGER 
 

6.1 Mail\Authentication 
 
This setting define the authentication method used when connecting to the 

SMTP server (the outgoing mail server). Some SMTP servers require the login 
method while others need the method set to none. Ask your system 

administrator or e-mail provider for details. 
 

7. Other changes 
 

7.1 Main view\Visualisation of device status by color 
 
 

Colour    Meaning 
 

red    alarm 
green    normal * 

blue    normal, cycle running for blast chillers 
yellow    particular statuses (e.g. defrosting) 

grey    not selected/inactive 
orange    alarm reentered 

 
7.2 Adding manually a device 

 
After having added manually a device, it is now necessary to configure its 
network properties in device menu\configure\network and select it. 
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Introduction

Introduction

RICS (Remote Integrated Control System) is a monitoring system for plants managed by equipment with MODBUS or

EVCOBUS communications protocols.

RICS is an ideal solution that respects international law for the monitoring of the magnitudes present in plants, for

example with the HACCP regulations regarding the treatment of foodstuffs.

RICS measures the working conditions of the machinery it is connected to 24 hours a day.

The heart of RICS is the software, which is very easy to install and to use.

RICS is currently available in 3 versions: Free, Advanced and Top.

This document refers to the Advanced and Top versions.

The main characteristics of RICS are:

• Real-time display of magnitudes taken by the devices (temperature, pressure, etc…)

• visualisation of alarm status with advanced diagnostic functions (only the Top version)

• detailed view of the status of each single device

• real-time modification of the parameters of each device (when allowed)

• recording on hard disk of data measured and of any possible alarm situations

• production of reports (that document the state of the plant) with charts (that can be rapidly and easily understood)

and tables (that are more precise and detailed); these reports can be printed or saved as various file types (Bitmap,

Excel, Word, Html, etc…)

• sending of e-mail, SMS Text Messages and fax to advise of any possible alarms

• possibility of personalising the graphical appearance

• protection of the configuration pages with different privilege levels, awarded based on username and password.

[ RICS ]Introduction
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1 Main Display

1.1 Introduction
The main window of RICS, hereafter referred to as the main display, allows the user to control the entire plant,

and highlights which and how many alarm situations are present at a glance.

From this page you can access all the other windows and functions provided by RICS.

Some functions can only be accessed by users that have the necessary privileges. Please refer to the user log-in

procedure for more information (see Chapter 2).

1.2 The main menu
This is the menu that appears in the main display (Screenshot 1). It allows access to the various system functions. Many

functions can also be reached in other ways.

Below you will find a description of the items that appear when RICS is set to English.

1.3 The status bar
The status bar (Screenshot 1) is the grey line at the bottom of the main display that shows messages and various informa-

tion depending on the programme status and the user settings.

Screenshot 1: Main display and important areas.

[ RICS ]Main display
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1.4 Device images
For each device connected to the system there is a video representation in the program that comprises a device

image, the device name and one or more fields that show the values, hereafter called the display (Screenshots

1 and 1.1). The device images (which hereafter we will refer to as just “devices”) are visualised on the main display,

where they can be moved around freely.

Screenshot 1.1: Single device image.

In order to allow RICS to manage the connected devices they must be associated to virtual devices, i.e.

representations of the physical devices within the programme. These virtual devices are given a graphical

appearance (the device image, that appears on the main display), a series of definable settings that indicate how

RICS must manage the data received from the device itself and the database of recorded information.

1.4.1 Manually adding a virtual device

To add or remove virtual devices you must have system installer privileges (see Chapter 3).

There are various ways of manually adding a device:

• with Device pop-up menu>Add device: just right-click on the field in the main display to open the device

pop-up menu (see Screenshot 1)

• with Main menu>Designer>Add device

• with the special button in Device designer.

After adding a device you must configure the communication parameters, amongst which are the

associated communications port and the address. To this end you should also refer to the paragraph that

covers the network scan function (see paragraph 1.4.2).

By pointing to a device with the mouse you can:

• gain access to the relevant Device status page (double left-click)

• open the Device menu (right-click)

• see information about the device with the Device inspector (see paragraph 1.5).

1.4.2 Network scan function

The network scan is a useful function to automatically add virtual devices associated to physical devices during the first

system installation. On this occasion RICS scans the network for devices and adds new virtual devices when possible.

This function can be activated from Main menu>Configure>Devices network. Then click on Next until you

reach Scan devices network.

If the scan does not see a device, add it manually (see paragraph 1.4.1).

Note that RICS maintains existing associations between virtual and real devices (where possible) to avoid changing the

settings without the user paying due attention to that change. Otherwise some recorded data may become inaccessible or

could be associated to the wrong device by mistake.

1.4.3 Visualisation of device st atus by colour

The displays associated to the device images will have different colours to indicate:

Colour Meaning

red alarm

green normal

yellow particular status (e. g. defrosting)

grey not selected
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1.5 The device inspector
The Device inspector allows you to visualise the status of the outputs, the value measured by the main probe, the

setpoint and the machine status of the chosen device, without leaving the main display. You can allow the display

of the Device inspector on Main menu>Configure>General>Lay-Out/Graphics>Device Inspector. After

this select the option Sticked to main panel.

Just click on a device or, if the function has been set, hover over the chosen device icon with the mouse for a few seconds

to see data from the Device inspector.

1.5.1 Display of the value measured by the main probe

The values measured by the first probe are seen in a large font for easy reading, even if the device image (and related

display) are very small.

1.5.2 Display of general st atus

defrosting: defrosting now

temperature reduction: reducing temperature.

1.5.3 Display of input and output st atus

If the device displayed has relay outputs or input contacts, you can see their current status on a series of virtual LEDs.

Note that in many cases the input contacts can be seen as active, or not, depending on the type of device, the type of

external contact and the eventual programming of the parameters.

You can see the name associated to an input/output by moving the mouse pointer over the relative virtual LED.

1.5.4 Display of the device’ s main setpoint

For many sorts of device (where there is the concept of main setpoint) you can see the value of the main setpoint on the

Device inspector.

1.5.5 Rapid modification of the device’ s main setpoint

You can rapidly modify the value of the main setpoint on the Device inspector. Just click on the displayed setpoint value

to activate the field that allows it to be modified.

This function can only be accessed if you have sufficient system privileges (see Chapter 2).

1.6 Virtual rooms
On the main display you can display all connected devices. However in some cases it can be helpful to sub-divide the

devices in sub-groups, displaying them one at a time.

In RICS these groups are called virtual rooms (or more simply “rooms”).

To modify the settings of these virtual rooms go to Main menu>Configure>Pages/rooms (see paragraph

7.1).
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2 User log-in procedure (local)

2.1 System privileges (privilege levels)
A system that is based on usernames and passwords inhibits access to some functions if the user does not have the right

permissions. In this manual these permissions are called privileges. A classic example of their use is that of

preventing non-expert users from accidentally modifying the program settings. Moreover some functions and

displays are hidden if the user does not have the necessary privileges. In this way the normal use of the programme

by most users is simpler, as it only shows the functions that are used and permitted.

In RICS these privileges are organised with a hierarchical structure based on privilege levels. The lowest

privilege level is Level 0, the highest Level 5. These various privilege levels are associated to user profiles.

2.2 User profiles
User profiles allow the association of different privilege levels to different users.

Each user profile is identified by a username and a password (compulsory).

Each user profile is also associated to certain properties, amongst which the main one is the privilege level.

To access the system a user must first perform the log-in (or identification) procedure.

2.3 The log-in procedure
This can be accessed through the Main menu>Security>Login.

Input the username or chose it from the list. There is no difference between upper and lower case.

When a user profile or password is not recognised by the system a “password incorrect” message is displayed.

If the account and password are accepted, the user’s name is displayed on the status bar along with their privilege level

(Screenshot 2).

Screenshot 2: Username and privilege level.

2.3.1 Log-in at inst aller level af ter the first inst allation of RICS

Follow the log-in procedure and specify the installer’s username and password (see Chapter 19).

Check the pre-set password table (see Chapter 19).

If the password is not accepted this means that it has already been changed. If you have forgotten the password then

contact the EVCO Help desk.

You can modify the pre-installed user profile data or add others by going to Main menu>Configure>Accounts.

This function can only be accessed by a user at administrator level or above. Default accounts are related in

the Certificate of Authenticity.

2.4 The log-off procedure
In Main menu>Security>Log Off you activate the log-off procedure, which returns the system to privilege

level 0. Nearly all functions are inaccessible at this level. Obviously RICS will continue to function and record

data.

Perform this procedure after configuring the system to protect against accidental modification of the settings.

[ RICS ]User log-in procedure (local)
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3 Data storage

RICS records the values of the magnitudes detected, the status of digital input and outputs, alarm conditions, etc… with

three methods:

• Sample recording (regular intervals).

• Event recording (not linked to regular intervals).

• Variation recording.

Some information is recorded in samples, such as the values measure by probes, while others are event-driven, such as

alarms. Finally for other information, where constant variation is not expected, we use variation recording (for example

the value of the main setpoint of a thermoregulator).

RICS also offers other advanced functions such as:

• It suspends sampling if the device is on stand-by status (only the Top version)

• It suspends sampling if the device is stopped (only the Top version)

• It performs extra recordings during particular alarm situations.

3.1 General functions
3.1.1 Basic sampling interval

The sampling period can be set on Main menu>Configure>General>Recorder (Screenshot 3).

Screenshot 3: Configure General – Recorder interval screen

[ RICS ]Data storage
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Example: to perform 4 samples every hour, set 15’ (15 minutes). If the process starts at 10:00 you will obtain the

following recordings:

10.00

10.15

10.30

10.45 etc…

The shortest sample interval is 30 seconds.

If you want to manage a large number of devices at the maximum sampling speed, ensure that the PC you are using is

adequate. If it is not then the system may be slowed down.

3.1.2 Different sampling depending on the device

You can use up to 4 sampling intervals, which are multiples of the basic one, to manage slow and rapid processes at the

same time and thus reducing the volume of recorded data.

These settings must be managed for each device, on: Device menu>Recorder (see paragraph 11.5).

3.1.3 Variation recording of the main probe

If the value measured by the main probe of a device should change significantly you can memorise the trend outside

normal sampling, so as to have a more precise trend in the reports that will be produced; this is only possible if the

Recorder Events button on the Device configuration Page is active (see paragraph 11.5).

3.1.4 Alarm recordings

If an alarm condition occurs then an event is recorded that describes its nature.

When foreseen, it also records the value of the probe associated with the alarm condition.

3.2 Files produced
RICS records information in an archive comprising files in proprietary format, which can therefore not be directly

interpreted by other commercial programmes such as NotePad, Word, Excel, etc…

The file, which is recorded in real-time, is supwin.rec, found in the RICS installation directory in the

\STATIONS\LocalHost folder. A copy of supwin.rec is also saved in the \STATIONS \DATA\Supwin.rbk folder.

Less recent data is found in the \STATIONS\LocalHost\DATA folder.

RICS keeps a list of folders in the \STATIONS\LocalHost\DATA\supwin.rdl file.

Warning: The files must not be modified in any way, because this would lead to errors in the reading

and interpretation of the files, making it impossible to produce reports.

3.3 Fragment ation of the archive and backup functions
The archive is fragmented and only maintains recent data in the Supwin.rbk folder.

To activate this function see Chapter 10.2.2.

In this case, when the current Supwin.rbk archive contains enough data, the file is re-named at the current date. The new

file is found in the supwin.rdl index file, and a new supwin.rbk file is created.

3.4 Data Backup
3.4.1 Manual backup

You are advised to make a regular copy of information stored by RICS, in a CD-ROM (or ZIP or USB Key-drive, etc…).

In this case it is also a good idea to save the configurations.

It will suffice to save the entire contents of the LocalHost folder.

3.4.2 Automatic backup with RICS Client

You can perform automatic backup from another PC on the network (or by Internet or modem), by installing the RICS

Client software on it. See Chapter 14.
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3.5 Occupation of space on the Hard Disk by recorded data
The Hard Disk space needed to record years of information depends on various factors, such as:

• Number of devices connected

• Sample frequency (recording)

• Types of devices connected

• Type of values sampled (temperature with a decimal point require more space than an integer value)

• Number of alarms that occur.

In general on a normal PC you can record years of data, even with the most extreme hypothesis.

Examples:

• An exaggerated estimate that considers 20 devices with 3 probes, decimal point management, and a sampling

frequency every 15 minutes with a certain number of alarms in the year comes to less than 2 megabytes per month

(24 hours a day). Therefore in this hypothesis the required space is around 20-25 megabytes per year. A CD-ROM

can therefore contain the equivalent of more than 30 yrs of samples. Note that compressing archived data (average

compression ratio 1:12-15 between original megabytes and compressed megabytes) substantially reduces the space

required. Therefore a CD-ROM could contain the equivalent of more than 400 yrs of compressed recordings.

• An even bigger hypothesis, considering 60 devices with 3 probes, decimal point management, sampling frequency

every minute and a certain number of alarms in the year will mean 80 megabytes per month (24 hours a day). In this

hypothesis, the space required becomes around 1,000 megabytes per year. Two CD-ROMs can contain the equiva-

lent of a year of uncompressed data.
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4 Report generation

4.1 Direct device report s
In order to rapidly see the most recently recorded data on the hard disc for a particular device, there are two methods,

which are:

• Right-click on the device, choose Report and then one of the following choices:

- Chart

- Table

- Events

- HACCP.

• Double left-clicking on the chosen device: the Status page (Screenshot 4) of the device itself appears. Click

on the Chart or Table button.

Screenshot 4: A device status page.

To produce a chart or table for a given device, the programme uses standard report models, or the models shown in the

page that can be reached through Main menu>Configure>Devices>Advanced>Reports (see paragraph 11.6).

In standard reports, RICS pre-selects some variables, for example for an EVK-series thermostat it displays the tempera-

tures of the probes present.

If you want to see the recent data for all the events recorded by the system, go to Main menu>Store

data>Reports>Events. A window will then appear containing the dates that define the interval for which you

want to display the data, with the Report type already set as TABLE. If the settings shown are considered

suitable, just click on Execute.

[ RICS ]Report generation
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By Events we mean alarms, the start-up and turn-off of the programme, device connection problems, system log-

in procedures, changes in settings, etc…

4.2 Creation of a new report model
A report model is a special file that defines what data we want to study, from which devices and which events.

In the RICS installation directory, in the REPORTS folder, there are standard models used by the system that have

a “.mml” extension; this folder also contains the STANDARD sub-folder which contains a copy of those models,

that can be used, for example, to restore one of the models if it should be changed by mistake.

Models created by the user must be saved with the “.rml” extension.

4.2.1 Creating a model

To create a new model go to Main menu>Store data>Reports>New report.

A wizard appears (New Report model, Screenshot 4.1), that will guide the user in the various choices with a few

windows:

• When you click on Add device after choosing the device that you want to create a model for in the first

screen (see Screenshot 4.1.1) you can choose which devices and elements (probes, inputs, outputs, setpoint,

etc…) of the device you want displayed or which events must be in the report. If an item is not visible, cancel

the device from the list of selected devices and add it again. To remove a device, select it on the list and click

Remove device. To display other events to be included on the report, click Add other events. To select

events that you want to be on the report, choose them by selecting their checkbox. To select all devices click

the Add all Devices button. To cancel all of the selections made up to now for the creation of the report

click on Cancel all. Choose the options you want then click on Next.

• In the second screen (see Screenshot 4.1.2) you can choose the period of the report. Choose the options that you want

and click Next.

• In the third screen (see Screenshot 4.1.3) you can define the title and the type of report (chart, table or you can decide

that the user can choose the type each time), the printer that will print the report (in the case of a model used for

automatic printing) and if you want to save the model that you are creating (if you intend to use it again). Select the

options you prefer and click on Next.

• In the fourth screen (see Screenshot 4.1.4) a summary of the choices made will appear, allowing the user to change

some of these at the last moment (such as the date or the type of model) or to modify the report that has

just been created by returning to the first screen, that you can reach by clicking on Modify. If the options

chosen are fine then you can obtain the chart or table that you want by clicking Execute.

To see the various screens, use the Next and Previous buttons.

There is an example of a chart created for device 4 in Screenshot 4.3.

Screenshot 4.1: New Report Model wizard
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Screenshot 4.1.1: New Report Model wizard, first screen.

Screenshot 4.1.2: New Report Model wizard, second screen.

Screenshot 4.1.3: New Report Model wizard, third screen.
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Screenshot 4.1.4: New Report Model wizard, fourth screen.

4.2.2 Advanced Options

During the creation of a model, in the third screen, there is an “Advanced“ button that leads to a screen which

allows the user to specify further options that will characterise the model (Screenshot 4.2). In the R.I.C.S.

Database text field you can specify the source of data used by the system to generate the report you desire;

normally it is supwin.rdl, which means it will look for data in all sub-archives automatically created by RICS.

Alternatively you can specify a sole .rbk sub-archive. In this case you must already know the time period of the

data that the file contains.

In the Charts group you can specify the minimum and maximum reference values which will be displayed on two

horizontal red lines in the chart.

Screenshot 4.2: Advanced window – third screen of the New Report Model.

In the Advanced options group there is a series of options:

• Automatic update of device descriptions: if selected, the device names that were saved during the

creation of the model will be updated every time (when the model is opened) if they are changed within RICS

(for example, if the device name changes from “meat cell”, before saving the report, to “fish cell” after

saving it).

• Alignment with AllDevices model: if selected, the model will always contain all devices, updated, in the

system.

• Display window for confirmation of dates: if selected, a display will appear asking for confirmation of

the dates (which is in the fourth screen mentioned in paragraph 4.2.1) every time the model is opened instead

of showing the report immediately.

• Generic device model: this option only appears when only one device was chosen in the selection screen

for data to be displayed (see the first screen mentioned in paragraph 4.2.1). If you activate the model created

for a certain device, that same model can be reused for other devices of the same type. The model created can

be associated to various devices (of the same category), in the Device configuration page (see Chapter 11),

that you can get to on:

• Configure>Devices>Advanced>Reports.
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Screenshot 4.3: Example of a chart created for a Fruit and vegetable Cold Store device.

4.3 Opening an existing model
To save a created model, you must select the Save option in the Save options field in the third screen of the

wizard mentioned in paragraph 4.2.1. The type of report created must be named and saved in a folder. RICS

suggests the REPORTS folder by default.

4.3.1 Opening a model that has been saved beforehand

To open a report model that has already been created go to Main menu>Saved data>Reports>Open. At this

point the window in Screenshot 4.4 appears: select and left-click the saved model that you want to open and click

on Open.

By the opening of a model we mean its calculation and execution, which will produce the chart or table containing the

values of the devices specified in the model.

Screenshot 4.4: Open window to open a report model that has been saved beforehand.

4.3.2 Modifying the displayed report

In the page that displays the data (table or chart visible on the display, Screenshot 4.3) you can modify the report by

choosing Reports>Configure on the menu, which leads to the display of the date confirmation window. At this

point if you click on Modify, a screen will be displayed that shows the elements in the model.

This way, for example, you can include a new column on a table, remove a device and all data related to it or even modify

the period of the data sample to be displayed.

4.4 Modifying an existing model
To modify an existing model go to Main menu>Saved data>Reports>Modify. At this point a window appears

from which you can choose the model that you want to modify.

By the modification of a model we mean the modification of the data/elements in it (and for which the report is

requested) and the modification of the attributes associated to the model itself.
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4.5 Charts
Charts are limited by the maximum number of definable points, based on the system resources available, the

sample interval used and the length of the period that you wish to display. If you use a very short sample interval

and you want to see the trend of the data for a long period, some intermediary values will not be shown. In this

case, the curve drawn is an approximation.

To obtain a more precise chart, increase the time interval chosen, follow Modify>Save scale on the charts menu

and double left-click on the chart, thus obtaining the re-calculation of the chart itself at a higher definition.

4.6 Tables
A table can contain a maximum of 10,000 (ten thousand) lines.

A table can be displayed in compressed mode, condensing a certain number of samples in a single line if the data remains

constant (Advanced>Compress lines).

During the showing of the table unselect Edit Enable color mode to save the toner of the printer.
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5 Diagnostics

5.1 RICS Diagnostic functions
In RICS you can distinguish three types of alarm, based on the origin of the alarm signal:

• Local device alarms.

• RICS generated alarms, after the comparison of the magnitudes measured compared to threshold levels or reference

conditions.

• Lack of connection alarms. These are also generated by RICS, and can indicate that the device is turned off, or

broken, or that the connection has simply been interrupted.

The alarm status is displayed on the screen, recorded in the database and a communication is sent by e-mail, fax or SMS

Text Messages Text Messages.

Moreover, an alarm condition may lead to a relay being turned on, if a hardware module has been connected to RICS that

is suitable for the purpose, such as module IFC29.

5.1.1 Local device alarms

The devices connected to RICS, that are based on microprocessors, can be simple data collection modules or complete

electronic control systems (thermostats, cold-room control systems, for temperature reducers or ovens, dedicated appli-

cations, etc…).

Generally, even the simpler devices can control the correct connection of sensors and their functionality. If the device has

a display, buzzer or alarm LED, the error condition is shown directly by the device.

If the device is not a simple sensor or data collector, but a more complex device, it may have very evolved internal

diagnostics that can advise users regarding tens of distinct anomalous conditions, managed through delays, reference

thresholds, inhibitions based on the machine status etc… The control systems manage the anomalous situations locally

with the correct behaviour.

“Intelligence”, in this case, is shared. Some examples:

• Antifreeze alarm: the value shown by a sensor is monitored and if the temperature drops below the given threshold,

the control system activates a buzzer, or an alarm relay, and also turns on the antifreeze circuit. If the conditions

persist or worsen then the control system blocks the output.

• Manostat alarm: A digital contact reads the existence of excessive pressure in a manostat. The control system turns

the compressor off until the alarm conditions return to normal.

• Open door alarm: the device control system gives an acoustic warning if the door is open and if it is not closed within

a certain pre-established lapse of time.

RICS can read the status of local device alarms, and store their status on the computer, send warnings, etc…

RICS answers local device alarms with delays, inhibitions and warnings.

For example you can set RICS to warn about the Open door alarm on a device with an e-mail 1 hour after the

alarm itself has been activated.

This allows staff to close the door, after having heard the acoustic alarm, before sending a useless warning to the alarm

control service.

Note that the inhibition of a local device alarm on RICS does not mean that the alarm is not taken into consideration: in

fact it will appear anyway on the physical display device indicating the plant that has an alarm condition.

[ RICS ]Diagnostics
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5.1.2 RICS generated alarms

RICS can generate alarms by comparing the value of data coming from sensors to reference values.

The types of alarm managed by the software are:

• Threshold alarm on analogical input (minimums or maximums)

• Alarms on the status of digital input (binary contacts).

This way you can implement diagnostic capacity with simple sensors or simple electronic controls, or you can extend the

devices’ resident diagnostics (i.e. the control systems on the device itself).

For example in RICS you can set-up a pre-alarm condition, which will not be read by the electronic control system in the

field, so as to anticipate really critical situations.

5.2 Device alarm conditions
If a device alarm is activated:

• The display of the device image is shown in red, and may be flashing if that option is chosen

• The virtual room (see Chapter 7.1) that contains the device shows an alarm condition

• RICS performs tasks described by the alarm category for active alarms (see paragraph 5.4; note that in the Advanced

version there is only one category).

5.3 Alarm manager
To see the Alarm manager go to Main menu>View>Alarms manager.

The alarm manager displays a table (see Screenshot 5) showing the alarm status for each device in RICS.

Screenshot 5: Trouble Shooter window.

If, for example, a device has two active alarms and one alarm that is over, the STATUS column will show: “3 alarms to be

checked”.

In the Options menu of the Trouble Shooter window you can filter the data displayed with the options:

• Include all devices: if chosen, this will display all devices including those without active alarms

• Include only selected devices: if chosen the table will not include the “deselected” devices in RICS (to

select/deselect a device see Chapter 11)

• Show all active alarms: if chosen the display shows a description of all the active alarms or alarms that are

over for each device and not only an indication of how many alarms must be checked

In the File menu you can print or save the table that you are looking at in Excel, Word, html or text format.
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5.3.1 Alarms that are over

Alarms that have been activated and for which the alarm conditions have ceased to exist are considered alarms

that are over. For an alarm that is over RICS displays the initial occurrence, the duration and other associated

information, until the alarm is reset (see paragraph 5.3.5). This means that the last anomalies or critical

situations measured are easily accessible, without forcing the operator to search for them amongst the historical

data.

It is enough to bring up the Alarm manager Page to verify whether there have been any problems in the plant.

5.3.2 Alarms with automatic deactivation

Normally alarms in RICS are automatically deactivated. This means that when the reason behind the alarm

ceases, the alarm is deactivated by the software. In this case the alarm is given the status of alarm over.

5.3.3 Alarms with manual deactivation

This function is only available on RICS Top Edition.

You can set RICS so that an alarm requires manual deactivation. This means that when the cause of the alarm

ceases to exist, RICS maintains the alarm signal until it is manually deactivated. Normally this corresponds to an

inspection by a member of staff.

5.3.4 Alarms with manual deactivation counter

This function is only available on RICS Top Edition.

You can set RICS so that an alarm is considered normally as an alarm with automatic deactivation, unless it is repeated

over a certain period of time, at which point it will require manual deactivation.

An example of use is the following: A maximum pressure manostat measures alarm conditions occasionally (if over-

loaded), thus protecting the machine. Upon the restoration of normal operating conditions the machine is reactivated,

and the alarm signal is deactivated. RICS copies the machine’s diagnostics by deactivating the alarm signal too. If

however the alarm is repeated regularly, this is an indication of a problem in the machine or the plant. In this case, RICS

maintains the alarm status even when the reason behind it ceases to exist.

5.3.5 Manual global Reset of all alarms

In the Alarms manager window menu, in Action>Reset all alarms, you can reset the status of all alarms

(counters of the number of activations, times etc…) of all the devices. This decision cannot be cancelled and can

only be performed by users with a certain user profile.

The alarm reset also deactivates a manual alarm whose cause has ceased to exist.
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5.3.6 Display of the list of alarms of a device

From the main page of the Alarms manager you can reach the page containing the alarms for a particular device (see

Screenshot 5.1), by clicking on the name of the device itself.

Screenshot 5.1: Page showing the alarms on a single device.

You can apply a filter for the data that is displayed on this page too by clicking on one of the buttons at the top:

• Active: only displays the active alarms on the device.

• Active/Terminated: displays all active/ended alarms on the device.

• All: displays all alarms associated with the device. An alarm can be active, over, or inactive; moreover an

alarm can be enabled (when an alarm situation occurs it signals the alarm) or disabled (when an alarm situation

occurs this does not lead to an alarm).

The screen shows the main information associated with each alarm.

In this table the colours used to describe the alarms are:

• Red: active alarm

• Purple: the alarm is about to trigger but has not done so yet (it may already be active in the real device but

there is a delay associated with it in RICS)

• black: alarm not active or is over and enabled (this can also be an alarm that is over)

• grey: alarm non enabled.

At the bottom of the page there is a Reset All Alarms button that cancels the status of all the device alarms selected.
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5.3.7 Display of the status of a specific device alarm

From the device alarm page (Screenshot 5.1) you can access the page regarding a single alarm (see Screenshot 5.2), by

clicking on the chosen alarm.

Screenshot 5.2: Example of a page showing a single device alarm.

This page is organized into two sections:

• Details: shows alarm information. If you have chosen to use Advanced diagnostics (on Main

menu>Configure>General>Alarms and selecting the relative checkbox), then on the page in Screenshot

5.2 there will be a checkbox called Extended diagnostics. By selecting it, the information about the alarm

is very detailed; if this information is hard to understand for an inexpert user you can deselect the Extended

diagnostics checkbox or indeed not use Advanced diagnostics: in that case only essential information will

be shown.

• Settings: by clicking on this button you can modify the settings for the various types of alarm (see paragraph

5.3.8).

In both of these sections you can display the various types of alarm using the arrows at the top-right of the page.

5.3.8 Modification of the settings for a specific device alarm

The settings associated with an alarm that can be modified in the Settings section are:

• Name ->The name to be associated to the alarm.

• Label ->Is the short-name to be associated to the alarm; this is used in some programme functions (for

example when sending SMS Text Messages Text Messages, where space is limited).

• Enabled ->If this checkbox is selected, the alarm is enabled. An alarm that is not enabled is ignored by the

system.

• Action (only the Top version) ->This is the action described in the Alarm Category that occurs when the

alarm is activated (the alarm must be enabled). To set the actions see paragraph 5.3.

• Alarm restore time: it allows setting the mode the normal condition is restored (Automatically, Manually

or Manually after the alarm has arisen a number of times you can set)

• Clear counters time (only the Top version) ->This is the lapsed time after which alarm counters are reset;

for example it cancels the counter that shows how many times the alarm has been triggered.

• Alarm characteristic\PC settings\Alarm condition delay ->This is the delay to be added to the time

when the alarm is activated before RICS also considers it active; for example, the alarm may be active on a

physical device but not be advised by RICS in so far as the associated delay has not yet passed.
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In the case of threshold alarms managed by RICS there is also:

• Threshold (only the Top version) ->This is the reference value beyond which the alarm is considered

activated

• Delta (only the Top version) ->This is the hysterisis used for the alarm when over. The alarm source becomes

inactive when input data moves under the threshold increased by the delta. The delta is an absolute value that

is subtracted (maximum alarm) or added (minimum alarm).

• Polarity (only the Top version) ->by selecting this checkbox, an input that is normally short-circuited

triggers an alarm if open.

In the Details section there are three buttons that allow you to reset the alarm (Reset Alarm), or to clear an

alarm (an alarm that is over and re-set is no longer considered an alarm that must be displayed), to ignore an active

alarm (Bypass Alarm) or to record HACCP information (Record HACCP info). The alarm is ignored for a

pre-established period, decided by the system.

Screenshot 5.3: Example of a page showing a single device alarm.

5.3.9 Modify the name of an alarm

As you will have seen you can modify the name of an alarm. This way you can adapt and specialise the descriptions

automatically chosen by RICS depending of the type of device.

For example, the “digital input” alarm of a device can be personalised as “security manostat”.

5.4 Alarm categories (the Advanced version has only one category)
You can define an RICS behaviour for each alarm condition by defining an alarm category. An alarm category is associ-

ated to the action to be performed when an alarm is activated (see paragraph 5.3.6).

In RICS you can define ten different alarm categories.

To configure the various alarm categories go to Main menu>Configure>General>Alarms>Alarms Category

Manager>Setup or Main menu>Configure>Alarms Category Manager (see Screenshot 5.4).

Screenshot 5.4: Setup Alarm categories window.
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By clicking on the General button, for each alarm category you can define, (see Screenshot 5.3):

• Name (ID): name of the alarm category

• Enable sound (PC): it activates the speaker of the Personal computer during this kind of alarm category;

the checkbox Enable sound of the frame Global settings must be selected

• IFC\Activate buzzer: triggers acoustic alarm of interface IFC29

• IFC\Activate k1: activates relay K1 of interface IFC29

• IFC\Activate k2: activates relay K2 of interface IFC29.

The last three checkboxes are visibile on condition that the IFC module is enabled (Main

menu>Configure>Devices network).

If you click on the E-mail button (or Fax or SMS) you will find the following options:

• Enabled: allow sending of e-mails

• Destination: destination e-mail address (you can define up to 3 e-mail addresses)

• Delay (only the Top version) : time that passes between the activation of the alarm and the sending of the

e-mail message to the associated addresses.

Note: the same fields in the e-mail section are also found in the Fax and SMS Text Messages sections. To use this

message service during an alarm you must first activate the general e-mail, FAX, and SMS Text Messages sending

service. These services can be set-up on Main menu>Configure>Messenger.

Lastly, and for every alarm category, with the Auto reset field in the Advanced section you can specify after how

much time an alarm that is over will be automatically reset by RICS (only the Top Version); in the same section

it is possible to enable/disable the category.

The settings selected through the frame Global settings will be applied to all alarm categories.

5.5 Advanced Diagnostics Mode (only the top version)
Note: This mode is only available in the RICS Top Edition.

If you choose to use Advanced Diagnostics (in Main menu>Configure>General>Alarms and selecting the

relative checkbox), the Extended Diagnostics checkbox appears on the page in Screenshot 5.2. If you select it

the information shown for the alarm will be much more detailed.

Depending on the type of alarm, they can be split into macro-sections (see Screenshot 5.5), for example:

GLOBAL Section. This shows global information for the alarm concerned, such as:

• Time of first activation

• Time of last de-activation (last time that the alarm was over)

• Counter for the number of times the alarm has been activated

• Worst value reached for the magnitude that the alarm controls (for example the value measured by the main probe)

CURRENT ALARM Section. This contains information regarding the current alarm status, such as:

• Time started

• Duration

• Worst source value (the alarm may not have been activated)

• The time the worst value was read (the alarm could have been in delay phase)

• Worst source value, but with an active alarm status

• The time the worst value was read, with an active alarm status

LAST ALARM Section. This concerns information regarding the last state in which the alarm was active, such as:

• Initial time – end time

• Time during which the worst source value was read (the alarm may not have been activated yet)

• Worst value on alarm

• Time during which the worst value was read, but with alarm activated

SOURCE Section. This concerns information about the source of the alarm, such as:

• Origin: can be the device or a PC alarm

• Value read on the associated probe

• Time of last activation

• Last duration of the alarm

• Worst value read during the last alarm activation

• Counter of number of times the alarm is triggered

• Worst value read during all alarm activations
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• Greatest duration of the various alarm activations

SETTINGS Section. Concerns information about the settings used by RICS for recording alarms, such as:

• Enabled

• Threshold (see paragraph 5.3.8)

• Delta (see paragraph 5.3.8)

• Delay (see paragraph 5.3.8)

• Counter cancellation time (see paragraph 5.3.8)

• Maximum number of events (see paragraph 5.3.8).

Screenshot 5.5: An example of some alarm information that can be obtained with extended diagnostics.
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6 Global control p age

To get to this page go to Main menu>View>Global Control (see Screenshot 6).

Screenshot 6: Global control page.

You can send global commands to all devices connected to a plant, or present in a virtual room. For example you can

switch on/off all the light outputs of all devices with a light control and that can receive this command from the PC.

Of course this functionality in RICS depends on the type of fixed device and the functions offered by its drivers.

For example the “start defrosting” function triggered from the PC is normally allowed for all devices that foresee the

forced defrosting from the machine. However there are some devices for which defrosting, standby, etc…., cannot be

remotely controlled.

[ RICS ]Global control page
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7 Personalising the graphic display

7.1 Using the virtual rooms
In the main display you can represent all the connected devices, and gather them in one or more pages. Examples of this

sub-division are:

• When there are a lot of devices with large images and not enough space on the display, but when you don’t want to

compromise the scale

• When devices are placed in specific areas of the plant, such as for example floors, rooms or areas

• When devices are grouped together based on the specific functions they perform.

In RICS these groups of devices are called virtual rooms or pages.

You can set a different wallpaper for each page, in either .bmp or .wmf format. This wallpaper may be a drawing of the

plant (produced with graphics programmes or digital photos or even scanned floor-plans).

If you have two or more pages you can switch active room by clicking on the name of the room you wish to view (bottom

left-hand corner of the main display, see Screenshot 7.1).

If there is an alarm condition on one or more devices in a room, a small red rectangle will appear next to the name of that

room.

7.1.1 Wallpaper on the main display

You can enable/disable the display of the background in the main menu from

Main menu>Designer>Show background.

To change the wallpaper in the various rooms go to Main menu>Configure>Pages/rooms and choose the

desired wallpaper by clicking on the right folder on the File name row in the Background picture box (see

Screenshot 7).

Screenshot 7: Room Configuration window.

[ RICS ]Personalising the graphic display
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If there are several rooms then you must specify in which of these you wish to change the wallpaper, typing the

name on the first line and selecting Enable. Please refer to Screenshot 7.

You can choose the dimension of the wallpaper by clicking on Stretch.

To activate the wallpaper, click on Apply once it is chosen. To get to the wallpaper settings in the other rooms

use the Next and Previous buttons.

To confirm the existing settings just click Ok, and to leave without modifying anything press Cancel.

In Screenshot 7.1 there is an example of a room with changed wallpaper (a window that coincides with the main display,

there being only one room), by applying the options chosen in Screenshot 7.

Screenshot 7.1: Example of a change of wallpaper in one room.

7.1.2 Display of the main layout

When there is more than one room you can display yet another page for the general layout.

In this case the wallpaper used shows the entire plant (you could use a scanned floor-plan, for example).

The user can associate one area of the main layout page to one room, through the room panel.

The room panels can be partially overlapped. See Paragraph 7.1.3 for their use.

7.1.3 Activation of the room division mode

To add a new room go to Main menu>Configure>Pages/rooms.

Choose the desired room with the Next and Previous buttons and click on Enable. Note that the page is

displayed if it contains at least one device, even if it’s box is not activated.

Note that the string immediately above the Status bar shows all the rooms present.

7.1.4 Setting room properties

To summarise, the properties of a room are (see Screenshot 7):

• Name

• Enable

• Background picture\File name

• Background picture\Stretch

• Frame\Visible

• Frame\Position

• Frame\Dimensions.
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7.2 Personalising the device image
RICS automatically gives an image to each device depending on the model of device used.

There are two display styles for these device images:

• Simple

• Maximized

7.2.1 Simple image style

The simple style is a rectangular panel which contains the display, or the fields that show the value of the main magnitudes

measured by the device (for example the value of the temperature control probe in a thermostat). In this case the position

of the display is pre-determined. The simple image style is activated through Main

menu>Configure>Devices>Image, clicking on the Look button and choosing Simple in the Style box (see

Screenshot 7.4).

7.2.2 Maximized image style

Normally the image represents the characteristics of the electronic device used (for example, in the case of a cold-

counter, you see the image of the electronic thermostat that controls it and not the image of the cold-counter).

The maximized image style is activated on Main menu>Configure>Devices>Image, clicking on Look and

choosing Maximized in the Style box (see Screenshot 7.4).

It is always possible to associate other images to the various devices in .bmp or .wmf format, by going to Main

menu>Configure>Devices>Image (see Screenshot 7.2).

Screenshot 7.2: Device image setting window.
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The image file to be associated to a device can be set manually in the fields Image path and Image file (see

bottom of Screenshot 7.2) or clicking on the image preview and choosing the image desired in the various files and

paths (see Screenshot 7.3, picture file name window).

Screenshot 7.3: picture file name window to choose the device image.

You can modify the size and style of an image, by choosing the Look field in Screenshot 7.2, and modifying the

parameters of the Size field of the Style field (see Screenshot 7.4)

Screenshot 7.4: Device image configuration window – Look field.
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Still in reference to Screenshot 7.2, you can select the Displays button and then the number of displays per device

(in the Displays field), as well as their position by modifying the parameters in the Display pos field (see

Screenshot 7.5).

This way you can freely place the displays relative to the main device coordinates.

Screenshot 7.5: Device image configuration window – Displays field.

7.2.3 Device label name

A text label is associated to each device and is displayed next to the image. It shows the name of the device.

You can change the colour and the position of this label relative to the device coordinates by going to Main

menu>Configure>Devices>Image respectively.

If you do not wish to see the device name we suggest you position the label off-screen.

7.2.4 Device configuration p age

Here is a description of the pages that can be reached from Screenshot 7.2. That page is divided into sub-pages. The table

below shows the main settings they contain. You are advised to make some trial settings to better understand their

meaning. Some aspects have already been covered in this manual, while others will be examined further in the specific

sections.

Page Function

general this mainly allows the setting of the name and location of the device, understood as the position in

the virtual room

network describes the connection dettings to PC, Ports and the Protocol used and the device installation

methods on the PC as rgards the interface

image see paragraphs 7.2.2 and 7.2.3

alarm see Chapter 5

recorder mainly allows the setting of time intervals between one recording and another (also see Chapter 3)

advanced allows the setting of data display methods (charts ro tables) and the measurements units used by

the probes

web allows the setting of files to be sent by electronic mail
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7.2.5 Some examples of the use of a device images

By associating a null image you can only see the display, which can be placed on the page; this way you can obtain an

easy synopsis of the plant.

To associate a null image, go to Main menu>Configure>Devices>Image, choose the General sub-page and

write “none” in the General/Name field.

If you associate an image of the machine into which the electronic control connected to the display is inserted, it can be

easier and more intuitive to represent the logistical structure of the plant. To choose the image file use the procedure

described for Screenshot 7.3.

Note: before configuring the device image, deselect the Change automatically checkbox in Main

menu>Configure>Devices>Image>General.

7.3 Grouping devices in ‘Machines’
7.3.1 Machines and Devices in RICS terminology

Normally RICS software manages all connected devices as separate entities.

Each related image can be freely placed on the main display to as to allow the creation of synoptic tables.

However sometimes a real machine may be controlled by more than one electronic device (or the related data may be

sampled by more than one data-collection module). In this case it is helpful to group the device images which are

otherwise treated as independent. The concept that represents this situation is known as the “Machine” in RICS.

Therefore in RICS a “Machine”, is a group of one or more electronic devices.

Often the following procedure is followed to represent a machine comprising more than one device:

• The image of the main device (probably quite large) is associated to that which represents the machine

• The other device images are set as “null”.

In this case, when dragging the image you also drag all the other displays associated to machine component devices.

7.3.2 Machine identification

In RICS each machine is identified by a number grater than 0.

Normally the first machine is index number 1, the second 2, etc…

For all devices in a machine go to Main menu>Configure>Devices>General (see Screenshot 7.6): in the

Grouping field, set the Machine ID field with the number of the machine to which the device must be

associated.

Screenshot 7.6: Machine ID and Machine leader items.

7.3.3 Main device

One of the devices must be labelled as the main machine device, by selecting the Machine leader checkbox (next

to the Machine ID box, see Screenshot 7.6). In this case if the device that is the “main device” is moved from

the main display, the other devices that comprise the machine are moved at the same time.
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8 Automatic st art-up function

8.1 Setting the PC with BIOS configuration
Normally, standard PCs are factory-configured for domestic or office use. After an interruption in the power supply they

do not turn back on automatically but this operation must be performed manually with the power switch.

In all data logging systems (data recording), the recording must begin again automatically as soon as power is restored.

It is therefore necessary to configure the BIOS settings on the PC where RICS is running (the BIOS is a simple piece of

software on the PC).

Read your PC Manual to find more information about the BIOS.

Example of configuration with Award Medallion BIOS v6.0

1. To access the BIOS configuration press “Del” when turning on the PC

2. Choose Power in the menu in the configuration section

3. In the Power page select the Power Up Control sub-menu and press ENTER

4. In the Power Up Control page set the AC PWR Loss Restart item to [Enabled]

5. Leave the BIOS setup, saving the settings that you have just created.

8.2 Automatic st art-up of RICS when W indows loads
In order to ensure that RICS runs automatically when Windows starts running, the Run automatically the

program on Windows start-up checkbox, in the System setup window that can be reached on Main

menu>Configure>System must be selected (see Screenshot 8).

Screenshot 8: System setup window.

This window is even displayed during the installation of RICS. If the system used requires a log-in on start-up (e.g.

Windows2000), there will be a Log on section in the above-mentioned System setup window (Boot Page), in which you

should set the fields (User name, Password, Domain) with which the automatic Log-in to windows must be performed.

[ RICS ]Automatic start-up function
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8.3 Automatic system re-boot
Windows is not a system that is specifically created to run continuously. To optimise the running of RICS software is it

advisable to re-boot the system at regular intervals, for example after 7 days of continuous use.

You can set RICS for an automatic re-boot of RICS itself or of the entire operating system.

To access the page for automatic re-boots go to Main menu>Configure>General>Auto Reboot (see Screenshot

8.1). To enable this automatic re-boot function, click the Enable Shut-Down checkbox. By selecting the Only

at night checkbox, you can ensure that the re-boot only occurs between 11pm and 6am. In the Max running

time (Days) text field you can set the maximum time the system will run before a re-boot. If the Only at night,

checkbox has also been selected then once the set time has passed RICS waits for the nighttime period before

re-booting.

Screenshot 8.1: Auto Reboot page.

If the Reboot operating system field contains a 1, then each re-boot of RICS will lead to a re-boot of the entire

system. With a 0, the re-boot only concerns the RICS software and all its components. If it contains a value

greater than 1, then that value indicates the number of times RICS will be re-booted before the operating system

is also re-booted.

For example with a Max running time (Days) = 5 and Reboot operating system = 4

 we obtain:

• System re-boot (1)

• After 5 days, RICS re-boot (2)

• After another 5 days, RICS re-boot (3)

• After another 5 days, RICS re-boot (4)

• After another 5 days, RICS and Operating system re-boot.

Therefore with this setting we obtain a re-boot of the operating system every 20 days preceded by 3 partial re-boots (just

RICS).
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9 Messenger configuration p age

9.1 Messaging function
RICS can automatically send e-mail, fax and SMS Text Messages if requested to do so.

The text of the messages is compiled automatically and contains essential data concerning the plant and its status.

Thus you can receive information about the status of the devices, the magnitudes present, etc…

Generally after the activation of the messenger module, you should re-boot the system. This is due to the fact that RICS

only memorises the software modules used so as to minimise the space occupied in operating system resources.

To configure RICS to automatically send e-mail, fax or SMS Text Messages, go to Configure Messenger (see

Screenshot 9) on Main menu>Configure>Messenger.

Screenshot 9: Configure Messenger page for e-mail.

By clicking on the icons on the left you can set the message management for each of the methods shown.

9.1.1 Email

You can only send e-mails if there is an Internet connection and an e-mail box supplied by your provider.

The settings are collected in sub-pages (see Screenshot 9):

• Sending

• Settings

• Destination

[ RICS ]Messenger configuration page
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Sending sub-page (see Screenshot 9)

• Enable: activates the e-mail module

• Send periodically/ Enable: activates the automatic sending function

• Send periodically /Interval OK: decides how often e-mail will be sent if all is functioning normally

• Send periodically /Interval Alarm: decides how frequently e-mails will be sent in the event of an alarm

• On Event\E-mail on alarm: allows the user to enable the immediate sending function if there is an alarm.

If this checkbox is selected then for each single device you can set the sending of an e-mail in the event of an

alarm (see Chapter 11)

• Advanced/Minimum time: used to avoid too frequent sending of e-mail in the event of an alarm by setting

a minimum interval between one e-mail and the next

• Advanced/Auto-retry: specifies the number of automatic sending attempts in the event of an error (busy

line, no connection, etc…)

• Advanced/SMS compatible: if this checkbox is selected then a very simple e-mail can be sent that is

compatible with SMS Text Messages format, and can be send to the addressee as such.

Settings sub-page (see Screenshot 9.1)

• Server/ SMTP Host address: specifies the address of the mail server used to send e-mail. If you have a

programme such as MS Outlook, MS Outlook express or Messenger already configured for sending e-mail

then you can copy this data from the given settings. If you are not sure of this data then contact your e-mail

provider

• Server/User name: this is the username connected to the user’s e-mail profile used to send mail

• Server/User password: this is the password for the user’s e-mail profile used to send mail

• Identification/From address (E-mail): specifies the e-mail address that will appear as the sender of the e-

mail that is sent

• Identification/E-Mail from: this specifies the name of the RICS station that sends the message. This will

appear in the e-mail header and allows the recipient to immediately understand which station has sent the

message

• Internet\RAS name: specifies the name of the Windows RAS connection (Remote Access Service) that

RICS uses to access the Internet, should there not be a permanent connection. Generally this is called

ricsInternet. To create a connection go to the Windows Control Panel

• Internet/Serial port: this specifies the COM Port used for the RAS connection. It must be specified if the

line is shared for Fax and Internet access.

Screenshot 9.1: Configure Messenger for e-mail page – Settings sub-page.
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Destination sub-page (see Screenshot 9.2)

Three groups of addresses can be defined. In each group you can set:

• Address: specify the addresses to which the communications will be sent. For example: info@evco.it. If

there are multiple addresses these can be separated by a “;”

• Alarm: allows the sending of a message to this addressee if there is a new alarm

• Periodic: allows the regular sending of e-mail to this addressee with a frequency that will depend on the status

of the plant.

Screenshot 9.2: Configure Messenger for e-mail page – Destination sub-page.

9.1.2 Fax

RICS can send automatic Faxes if the PC has an external modem/fax or an internal modem/fax card.

In the case of an external modem, ensure that the equipment is not configured on the same COM Port that is used for the

Evcobus device network connection.

You can set up to three addressees.

The settings are grouped in sub-pages (see Screenshot 9.3):

• Sending

• Settings

• Destination
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Screenshot 9.3: Configure Messenger for fax page (previous page).

Sending sub-page (see Screenshot 9.3)

• The same as the e-mail page.

Settings sub-page (see Screenshot 9.4)

• Fax/Serial port: COM Port to which the fax module is connected

• Blind Dial: Selecting this checkbox allows an attempt to dial without checking for the telephone signal. It

may become necessary to enable this option if the PC cannot connect to the telephone line.

Screenshot 9.4: Configure Messenger for fax page – Settings sub-page.

Destination sub-page (see Screenshot 9.5)

Three addresses can be defined, with:

• Telephone number: specifies the fax number to which the fax must be sent

• Alarm: enables sending of communications to this addressee in the event of new alarms

• Periodic: allows the sending of periodical communications to this addressee with a frequency that depends on

the plant status.

Screenshot 9.5: Configure Messenger for fax page – Destination sub-page.
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9.1.3 SMS Text Messages

RICS allows sending SMS to the users informing them about the status of the plant.

To set RICS to send the SMS choose Main menu>Configure>Messenger>Sms>Settings; there are the

following opportunities:

• using a GSM modem

• using a SMS gateway (internet).

9.1.3.1 Using a GSM modem

Operate as follows:

• equip yourself with a GSM modem dedicated for this use, otherwise equip yourself with a mobile phone able to

work as GSM modem (these equipments are hereinafter called “device”); connect the device to the Personal Compu-

ter using a RS-232 or an USB connection (IRDA and Bluetooth connections are less reliable than direct connections

because of the presence of obstacles between the Personal Computer and the device, because of manual procedures,

etc ...)

• install the drivers supplied by the builder of the device (quite often they are available in the web site of the builder);

make sure possible further software are not running and are not using the communication port

• make sure the device is powered by the electric system, in order that the SMS service is always available (the

Personal Computer does not control the status of the battery of the device)

• put a valid and with credit SIM into the proper box of the device (the Personal Computer does not control the

validity and the credit of the SIM).

Keep operating as follows:

1. Start RICS.

2. Choose Configure>Messenger>Sms.

3. Make sure the checkbox Enable of the card Sending is selected.

4. Click the card Settings.

5. Make sure the radio button GSM Modem of the card General is selected.

6. Click the card GSM Modem.

Click Modems to gain access to the section of the Control Panel of the operative system dedicated to the properties

of the installed modems; close the window once you have noted the properties (if your connection to the modem is

via IRDA, Bluetooth or USB, there will probably be available a virtual COM associated to a high number).

7. Use the pop-up menu Serial port to choose the communication port where the device is connected.

8. Use the pop-up menu Driver to choose the driver of the device.

If the driver of the device does not belong to the list, choose a generic driver or the driver of a similar model (quit

RICS before using a new driver).

The standard drivers of RICS have been developed according to the ETSI GSM 07.07 specifications and according

to the ETSI GSM 07.05 one, in particular:

- GENERIC AT + EVCO (Text)

- GENERIC AT + EVCO (PDU).

Some modems are compatible with both the formats.

One suggests looking at the documentation of the device, in particular as to the implementation table of AT com-

mands to send SMS.

If no driver works, it is possible your device needs advanced settings:

- settings you have to operate on the mobile phone (enable the device to send SMS through commands received

on the USB/IRDA/Bluetooth connection)

- settings you have to operate in RICS through the button Advanced of the card Modem GSM:

§ the default baud rate is 19,200 baud (a few mobile phones need 9,600 or 115,200 baud)

§ the default parity is none

§ the modem init string is nothing; consult the documentation of the device as to AT commands

- settings you have to operate in Windows (Start>Control panel>Performances and

     maintenance>System>Hardware Tab>Device manager>Ports (COM and LPT).

9. Leave empty the text field Services Centre.

10. Leave empty the text field PIN (it is required only for particular devices belonging to the list).

11. Click the card Destination.
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12. Digit the phone number of the recipients in the text fields Destination international number inclusive, even

if the Personal Computer where RICS is installed and the recipient of the SMS are in the same Nation.

9.1.3.2 Using a SMS gateway

RICS integrates two SMS gateways, to allow sending SMS via internet, without using GSM modems.

The supported gateways are the following ones:

• SMSHosting

• Clickatell.

These companies are independent on Evco.

To enjoy this service, you have to create an account (username and password) on the internet site of the gateway:

• http://www.smshosting.it/smsMaster/registra.jsp for SMSHosting

• http://www.clickatell.com/central/login.php?prod_id=12 for Clickatell.

Once the account has been created, you have to log yourself in and purchase the number of credits you prefer.

The gateway Clickatell needs a phase more; operating as follows:

1. Choose Product Control, then COM Object.

2. Create an API_ID (this function is required to send the SMS).

Operate as follows:

1. Start RICS.

2. Choose Configure>Messenger>Sms.

3. Make sure the checkbox Enable of the card Sending is selected.

4. Click the card Settings.

5. Make sure the radio button By internet of the card General is selected.

6. Click the card SMS By internet.

7. Use the pop-up menu Provider to choose the gateway (if the names of the gateways are not available, it means that

they are not integrated in the RICS version in use).

8. Digit the username you have created in the internet site of the gateway in the text field User name.

9. Digit the password you have created in the internet site of the gateway in the text field Password.

10. Leave empty the text field Personal identifier; if you have chosen the gateway Clickatell, digit there the API_ID .

11. Click the card Destination.

12. Digit the phone number of the recipients in the text fields Destination international number inclusive, even if the

Personal Computer where RICS is installed and the recipient of the SMS are in the same Nation.

9.1.3.3 Using the button to test the SMS service

Through button Try it is possible to test if the settings are correct.

If you click the button you will save the new settings (RICS can signal some wrong settings).

If you have set no recipients the program will ask the destination number.

In some cases you have to reboot RICS; if the problem is connected to the operative system, you have to reboot it.
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Screenshot 9.6: Configure Messenger for SMS Text Messages page.

Destination sub-page (see Screenshot 9.7)

Three addressees can be defined, with:

• Telephone number: this contains the number to which messages must be sent

• Alarm: enables the sending of communications to this addressee in the event of new alarms

• Periodic: allows the sending of periodical communications to this addressee with a frequency that depends on

the plant status.

Screenshot 9.7: Configure Messenger for SMS Text Messages page – Destination sub-page.
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10 General configuration p age

You can reach this page from Main menu>Configure>General (see Screenshot 10).

Screenshot 10: General configuration page.

If the Configure item is not visibile or is disabled (in grey), it means that the function cannot be accessed with

the current log-in level. If you have the log-in details for a user profile that is enabled to perform this sort of

operation, follow the user log-in procedure (see Chapter 2).

The configuration page is divided into sub-pages, for each of which a series of settings can be made that modify the

functionality of RICS. These pages are:

• General

• Recorder

• Lay-Out/Graphics

• Options

• Alarms

• Auto Reboot

• Reports

• Installation

• Remote access.

Some fields and properties described are only accessible at installer level.

[ RICS ]General configuration page
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10.1 General
This page (see Screenshot 10) allows you to set:

• Identification\Station name: this is the name of the station where RICS is installed and is used in displays,

printouts and communications

• Exit Password\Ask exit password: if this checkbox is selected a password will be requested to exit the

programme. At installer level the password is not requested. Note that in any case you cannot prevent an

unforeseen interruption to the programme with the keys ctrl-alt-del (manual closure of Windows tasks) or

with the reset and on/off buttons on the PC.

After the first installation, the exit password is EXIT. It can then be changed if you have a privilege level of

administrator or higher.

10.2 Recording
This sub-page (see Screenshot 10.1) is divided into two sub-pages:

• Recorder: allows the settings of the general methods with which RICS saves data on the hard disk

• Backup: this concerns the automatic back-up of data.

Screenshot 10.1: General configuration page - Recorder sub-page.

10.2.1 Recorder

• Recorder interval: this specifies the basic interval at which RICS saves the measured device readings.

Remember that you can record the data from one device more frequently than that of another. This can be

done on the Device configuration page (see Chapter 11).

10.2.2 Backup (archive/fragment ation)

• Periodic backup\Enable: when this checkbox is selected the data will be fragmented automatically. This

means that non-recent data will be moved into another archive so as to reduce the size of the current archive.

• Periodic backup\Programmed backup date: this specifies when the automatic archive fragmentation

procedure will run.

• Periodic backup\Number of days for next backup: if this field contains a value other than 0, you can

automatically change the planned backup date when the backup procedure begins

• Mirroring\Enable: when this checkbox is selected, the backup functions of data will be active (in owner

format; this function is available only in the Top version of RICS)

• Mirroring\Destination: it allows setting the destination of the backup data (this function is available only

in the Top version of RICS).
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10.3 Lay-Out/Graphics
This page (see Screenshot 10.2) allows you to modify the graphical appearance of the main RICS display and specify

other settings:

• Other\Grid size: this field allow you to define the size of the grid upon which the virtual devices (device

images) are placed; this means that if the grid is small, the device can be moved by just a few pixels on the

screen. If the grid is large then the devices can only be moved by a large number of pixels on the screen.

• Other\Show Recycle Bin: by selecting this checkbox you can see a page with cancelled devices that can be

recovered.

• Default background\Picture path: this cannot be modified and displays the location of the wallpaper files.

• Device Inspector\Sticked to main panel: by selecting this checkbox you can see the Device inspector on

the main display.

• Device Inspector\Auto change (follow mouse): if this checkbox is selected you can easily choose the

device displayed by the device inspector, by hovering over the chosen device icon for a couple of seconds with

the mouse pointer.

Screenshot 10.2: General configuration page - Lay-Out/Graphics sub-page

10.4 Options
This page (see Screenshot 10.3) allows you to modify the following settings:

• Language: specifies the language used in the programme. These settings become active after re-booting

RICS. Remember that some messages and windows will appear in any case in the language chosen for the

Windows operating system. You may wish to change the International Windows settings too.

• XML Encoding: this allows functionality on operating systems with non-western languages, such as Chinese

for example. The default for Western languages is ISO-8859-1 (not changeable).

• Remember: if this field is not set correctly then errors may occur when displaying reports (tables, charts)

• Show Measure unit: selecting this checkbox allows the display of the units of measurement of the device

values, when this information is available and set-up correctly. Refer to Chapter 11.

• Color mode: when this checkbox is selected you can display the parameters and the internal status of devices

with different colours depending on the value reached and based on the description in the driver of each single

device. For example if a parameter value is beyond the limits set, then this value will be displayed in red.
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Screenshot 10.3: General configuration page - Options sub-page.

10.5 Alarms
This page (see Screenshot 10.4) allows you to modify the following settings:

• Behaviour on alarm/Show Alarms Manager: when this checkbox is selected then during an alarm the

Alarm manager window is automatically displayed, showing detailed information about the device alarm

status. If alarm conditions continue, the window is displayed again after a short time even if the user has closed

the Alarm manager. If the checkbox is deselected it is still possible to display the window from Main

menu>View>Alarms manager

• Behaviour on alarm /Sound on alarm: by selecting this checkbox, an acoustic alarm is heard every 3

seconds during an alarm. If the volume is too low or cannot be heard at all then remember to configure the PC

audio settings

• Behaviour on alarm /Device blink on alarm: when this checkbox is selected, during an alarm the display

connected to a device icon in the main display, will flash red every second. This means that alarm conditions

found will be very obvious. On slower PCs it is a good idea to disable this option so as not to slow the

programme down. If the option is disabled, then the device display is red but does not flash.

• Alarm Categories Manager\Advanced diagnostic (only the Top version): selecting this checkbox

enables the advanced diagnostics mode. In this case you can display a series of detailed information concerning

the alarms.

• Alarm Categories Manager \Setup: this button allows access to the configuration of the alarm categories

• Alarm Categories Manager \Apply to all (only the Top version): allows you to associate the indicated

alarm category to all devices and related alarms. Warning: when you close the page and after confirming

chosen settings, any eventual manual settings previously created will be lost.
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Screenshot 10.4: General configuration page - Alarms sub-page.

10.6 Auto Reboot
This page (see Screenshot 10.5) allows you to modify the following settings:

• Auto Reboot/Enable Shut-Down: selecting this checkbox, enables the Automatic operating system and

RICS re-boot function,

• Auto Reboot /Max running time (Days): indicates the number of days to count from the start-up of RICS,

before executing the automatic re-boot procedure. Remember that the re-boot begins when the count ends,

unless the Preferably at night option has been set

• Auto Reboot /Only at night: selecting this checkbox ensures that once the countdown has ended the

system waits for nighttime before re-booting the system

• Auto Reboot /Reboot operating system: indicates how frequently a complete re-boot should be performed

(including the operating system) compared to the RICS re-boot. For example with a setting of “2” you obtain

an alternation of partial re-boots (only RICS) and complete ones (see paragraph 8.3)

• Auto Reboot /System setup: when you click on this button two pages appear that show the names and Port

addresses of the PC upon which the software is installed

• Watchdog\Stay resident: selecting this checkbox means that the Watchdog programme is always enabled

and ensures that RICS is automatically re-booted after a manual shutdown of RICS.
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Screenshot 10.5: General configuration page - Auto Reboot sub-page.

10.7 Report s
This page (see Screenshot 10.6) allows the modification of settings connected to the creation of reports. It is divided into

two fields: Speed reports and Automatic print.

10.7.1 Speed report s

RICS allows you to set up to 4 direct connections to personalised report models. This means that with a simple click you

can request charts or tables that show the data you want and referred to the last hour, day, week etc.

• Speed report title: this is the title that is used in the report. If unspecified, nothing is shown.

• Speed report file name: this is the name of the .rml model to be used when the item is selected in the main menu on

this page (e.g.: cReport0.rml).

10.7.2 Automatic print

RICS allows the automatic printout of saved data. This function is normally used on line printers but works with any sort

of printer.

• Enable: by selecting this checkbox the automatic printout function is enabled

• Next operation: allows you to specify the time at which the printout will occur.

• Ignore printer status: selecting this checkbox allows data to be sent to the printer even if is shows an error or if it is

busy

• Interval: specifies the delay after which the automatic printout procedure will be run

• Setup: this button allows the display of the auto-configuration window which in turn allows the modification

of the model used for the automatic printout function, specifying for which devices a printout must be

produced and for which device measurements.
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Screenshot 10.6: General configuration page - Reports sub-page.

10.8 Installation
This page (see Screenshot 10.7) allows the modification of settings regarding help or regarding RICS extensions.

It is divided into two sub-pages: General and Plug-Ins and Tools.

10.8.1 General

• Internet settings/Send E-Mail to us: this is the Help Desk e-mail. It can be set so that the end-user can

send an e-mail to the help-desk if needed. The programme used to send the e-mail is that which Windows

associates to e-mail function by default. You need an Internet connection to use this function.

• Internet settings/Visit our web site: this is the help-desk internet site. You need an Internet connection

to use this function.

10.8.2 Plug-Ins and T ools

RICS allows you to set up to 4 connections that go to external applications or RICS extensions developed by third-

parties. If at least one extension has been defined then the Tools item will appear in the main display menu. The

fields in this page are:

• Title: this the title that is used on Main menu>Tools. If this box is empty, the Tools item is not included

• Command Line: this is a command line associated to the item. You can also specify just a file name. In this

case the file is opened with the application to which the file type is associated, in the same way as with

Explorer in Windows

• Level: indicates what is the minimum level of privilege needed to access the item.
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Screenshot 10.7: General configuration page - Installation sub-page.

In the Top version the checkbox Show keyboard is available. Select this checkbox to get the program to show

the path Main menu>Tools>Keyboard to allow showing Windows’ keyboard (and avoid connecting the real

one to the Personal Computer).

10.9 Remote access
This page is sub-divided into sub-pages, Internet and Web server (see Screenshot 10.8).

10.9.1 Internet

• Client Server/Setup: it allows setting the FTP port and the EDCS one.

• Internet/Internet connector\Enable automatic connection: selecting the checkbox, RICS can access

Internet

• Internet/Internet connector \Connect at startup: if this checkbox is selected then RICS will connect to

Internet when it starts-up.

• Internet/Advanced\RAS name: indicates which Windows user profile shall be used for Internet access. The

default is: ricsInternet

• Internet/Async mode (Windows 2000 or higher): make sure the checkbox is selected if the operative

system is Windows 2000 or higher

• Internet/Advanced\Serial port: this must contain the number of the COM Port that is specified by the

RAS user profile being used. It allows the system to avoid conflicts if using a modem/external fax on a COM

Port for sending faxes or for Internet connection. If you are using a RAS connection to access to Internet and

the modem is connected to a COM port of the Personal Computer, you have to set the same COM in the

dialog box Serial Port (COM).

If the Personal Computer has just a COM, the dialog box will not be available because the port will certainly be used

for tge communication with the device network.

10.9.2 Web server

• Web manager/HTTP Browsing/Enable: selecting this checkbox enables the RICS Web server service. This

service must be enabled if you want to access RICS via Browser

• Web manager/HTTP Browsing/Web server: specifies the name of the programme that implements the

web server service. Currently only evcoWebServer.exe is valid
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• Web manager/HTTP Browsing/HTTP Port: indicates upon which port the web-sever service must be

installed.Ensure that the port is not already being used by Windows

• Web manager/Web manager\Enable: if this checkbox is selected then the web manager is enabled

• Web manager/Web manager\Web center: contains the web server internet site.

Screenshot 10.8: General configuration page - Remote access sub-page.
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11 Device configuration p age

You can only access this page with administrator-level privileges (level 3).

There are 3 ways to get to this page:

• Double-left click on the device in the main display. This displays the device page. Now click on Setup.

• Right-clicking on the device, opening the device menu. Then choose Setup.

• Through Main menu>Configure>Devices (Note: this takes you to Device configuration page number 1;

to choose the device you want use the Next and Previous buttons).

The Device configuration page (see Screenshot 11) is divided into the following sub-pages:

• General

• Network

• Image

• Alarms

• Recorder

• Advanced

• Web

Screenshot 11: device configuration page.

[ RICS ]Device configuration page
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11.1 General
This page (see Screenshot 11) allows the setting of the following fields:

• General/Name: the name given to the device; RICS gives a default name to the device but it is certainly

better to assign a more significant name (e.g. “Meat cold-cell”)

• General/Nickname (only the Top version): it allows assigning a short name to the device. The short name

is used for example in the SMS’ text (if the field is empty, the program will use the long name)

• Grouping\Machine ID: assigns a value other than 0 to all devices that are part of a single machine (see paragraph

7.3)

• Grouping\Main leader: select the checkbox if the device in question is the main device (see paragraph 7.3)

• Grouping\Visual room: indicates which page must host the device. For more information about rooms see

paragraph 7.1.

• HACCP: it is possible to specify if the device is associated to HACCP functions.

Among the standard reports, there is the HACCP one; this model contains only information about HACCP. During

an alarm, the device is shown in the alarm manager with a red “H” (click over the “H” to obtain the report). In the

Top version it is possible to add a note about a particular alarm.

• Documentation\Change automatically:

• Documentation\Documentation: this is the filename of the technical document that is to be associated to

a device (for example it could be a .pdf file).

11.2 Network
This sub-page (see Screenshot 11.1) allows the settings for the association of a virtual device to the physical device on

the device network.

This section is further sub-divided into:

• Addressing

• Driver.

11.2.1 Addressing

• Network\Selected: if this checkbox is deselected, the device is excluded from data collection and it will not

be sought in the network nor is it included in the data saved to disk.

• Port: select VCom_A for the first sub-network and Vcom_B if there are two device sub-networks and the

device in question is connected to the second.

• Network address\Protocol: select the adequate protocol (Note: all devices in the sub-network must use the

same protocol).

• Network address\Address: defines the address of the device in the network (each device in the network has

a unique address; no two devices can have the same address). The address is set on the device manually (using

the device keyboard), when the network is created (these operations are explained in the Installation

manual).

• Network address\Profile: in reference to the point above, some devices are not recognised by the programme

with an address, but with a profile. The profile is therefore another method that the programme has to

identify connected devices.

• No link alarm\Threshold: this is the number of consecutive communications errors that will be tolerated

by the system before the device is considered as not being connected. Set a high number if the communications

line is poor quality or disturbed and therefore subject to communications errors.

If the protocol is Evcobus:

• Address is a value between 1 and 15

• Family is a value between 0 and 7

If the protocol is Modbus:

• Address is a value between 1 and 247

• Profile: for EVCO devices it is normally 1
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Screenshot 11.1: device configuration page - Network sub-page.

11.2.2 Driver

The settings in this section should only be changed by expert users and are only changed in some applications:

• Plug and play\Auto detection: You are advised to leave this checkbox selected. This will mean that RICS

can auto-configure some of the properties of the virtual device, compatibly with the type of physical device

connected

• Vtp driver extension: use to connect an extension driver, used for some devices. For standard devices there

is normally no extension driver.

11.3 Image
This page (see Screenshot 7.2) allows the definition of the graphical element of the device, or how it is seen on the main

display. This page is divided into 3 sub-pages: General, Look and Displays.

11.3.1 General

• General settings/Device pos: this field allows to set the (x,y) coordinates of the device image relative to

the top left corner of the main display

• General settings /Label pos: this field allows you to set the (x,y) coordinates of the device name relative

to the top-left corner of the device image

• General settings / Label color: this field allows the choice of the colour of the characters in the device

name

• Change automatically: deselect this checkbox if you want to personalise the graphic appearance of the

device

• Image path: this is only used in Maximised style (see paragraph 7.2.2). Generally [Default]

• Image file: only applies to the Maximised style. You can also change the image file by clicking the image

preview and choosing the correct file from amongst various files and paths (see paragraph 7.2.2).

11.3.2 Look

• Image/Style: this field allows the choice between maximised or simple style (see paragraph 7.2.1)

• Image/Size: this field allows you to enlarge or shrink the dimension of the device images (Note: the

dimensions of the device displays will be adapted proportionally)

• Image path: is the same field of paragraph 11.3.1

• Image file: is the same field of paragraph 11.3.1.
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11.3.3 Displays

• Displays\Front kind: this field allows you to define the number of display panels associated to a device

image.

• Display pos\ Display pos 2,3: this field represents the (x,y) coordinates of the panel relative to that of the

device.

• Display blank in off: by selecting this checkbox you can choose not to see anything if the device is in stand-

by status.

• Image path: is the same field of paragraph 11.3.1

• Image file: is the same field of paragraph 11.3.1.

11.4 Alarms
The following sub-page is shown in Screenshot 11.2. There are 3 sub-pages: General, Threshold Alarms and

Digital inputs Alarms.

Screenshot 11.2: Device configuration page - Alarms sub-page.

11.4.1 General

• Alarm Categories Manager\Setup: this button allows the display of the alarm category configuration

page.

• Apply to all\Apply: when pressing this button after having chosen a category in the adjacent scroll-down

menu, you can associate a certain behaviour to all the alarms on a device. Warning: this operation overwrites

all settings previously made as regards the behaviour of the device during an alarm.

• Settings\Advanced: this button allows the direct display of the Alarm manager settings for the device (see

Screenshot 11.3), so as to set/check all the properties connected to the alarm.
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Screenshot 11.3: Alarm manager settings for a device.

11.4.2 Threshold Alarms

In this sub-page (see Screenshot 11.4), for each analogical input (up to a maximum of 4) there is a panel that contains the

basic information about the threshold alarms managed on the PC (fields Delta are available only in the Top version).

You can set threshold alarm levels from this page, any eventual delays and the alarm-over delta. By selecting the relative

checkbox you can also choose to activate the minimum or maximum alarm or both.

Go to the Alarm manager page (see paragraph 5.3) for the complete settings.

Screenshot 11.4: Device configuration page - Alarms sub-page – Threshold Alarms sub-page.

11.4.3 Digit al input s Alarms

From this sub-page you can enable and set the polarity of digital input alarms managed by RICS.

Go to the Alarm manager page (see paragraph 5.3) for the complete settings.

Also see Chapter 5.
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11.5 Recorder
This sub-page (see Screenshot 11.5) allows you to set the parameters for the saving of data on the hard-disk (see

Chapter 3).

By selecting the Enable Recorder checkbox you activate the recording of data for the device concerned (Note:

Normally recording must never be disabled, if not when testing the system).

The Recorder Events checkbox allows you to decide whether to activate the recording of events. Typical events

can be alarm situations, connection loss, etc… By selecting this checkbox when an event occurs the information

about that event is recorded on the hard disk. Variation recording is also activated in this field.

There are two other checkboxes: Disable in Stand-By and Disable in Stop (only active if the device allows

these states). By selecting these checkboxes you can disable recording at these times.

In the On time options you can define the basic timing (or every how often data from the device must be

recorded) by setting the Record Interval field. By default this field contains the same time at which RICS records

data and in any case cannot be less than the general recording time (to get to the general recording time go to

Main menu>Configure>General>Recorder>Recorder Interval); it can only be the same or greater than

this. This group of options also contains the Sampled items field which highlights which devices (main probe,

probe 2, outputs, etc…) are monitored and recorded.

Screenshot 11.5: device configuration page – Recorder sub-page.

11.6 Advanced
This page (see Screenshot 11.6) is divided into the following sub-pages:

• Options

• Reports

• Analog I/O

11.6.1 Options

• GUI Descriptor: this field describes the file associated to the device that contains a description of the

graphic user interface of the device status page. You are advised to not modify this file which is automatically

created by RICS after it has recognised the devices.

• Items redefinition: this field allows you to personalise the names of inputs and outputs and associate a

descriptive file to them. See the Example.rid file in the RICS installation directory, in the STATIONS\LocalHost

sub-page.
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11.6.2 Reports

• Direct report (Chart): selecting the User defined checkbox you allow the user to specify the report model

that has to be associated to the device in question, for the generation of a direct chart.

• Direct report 2 (Table): this field allows you to specify the report model that has to be associated to the

device in question, for the generation of a direct table report.

11.6.3 Analog I/O

The scroll-down menus on this sub-page allow the user to select the measurement unit displayed for the magnitudes

supplied by analogical inputs. If they are linear inputs used to measure pressures, humidity, current and all other types of

magnitudes it is helpful to specify the measurement unit.

Screenshot 11.6: Device configuration page - Advanced sub-page.

11.7 Web
This page (see Screenshot 11.7) allow the modification of the settings for remote browsing of each device. You can set

the following fields:

• Remote browsing\Change automatically: selecting this checkbox allows RICS to set the web-pages for

a single device automatically. Only deselect the checkbox for a personalised installation performed by

qualified staff.

• Remote browsing\Web definition file: this file allows the specification of the web-page definition file

• Remote browsing\Picture 1: this file allows the association of an icon or image to a device web-page. The

image is visible in the device page that can be accessed via the web.

• Remote browsing\ Picture 2: this field allows you to associate a second image to the device. Currently this

information is not used in the standard RICS web-pages

Note: the use of images may slow web-page access if you do not have a fast internet connection.
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Screenshot 11.7: Device configuration page - Web sub-page.
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12 Configuration of user profiles

12.1 Profiles
You access this page from Main menu>Configure>Accounts (see Screenshot 12).

By user profile (username and password) we mean “who” is the user that at a given time is using RICS. Each user

profile has a privilege level, based upon which their access to some functions is enabled or forbidden. For example,

you can only reach this page if the user profile privilege level is greater than or equal to 3.

Screenshot 12: User profile configuration page.

12.2 Pre-defined profiles
Once the system has been installed you will find some user profiles already defined with different privilege levels.

12.2.1 Properties of a profile

The user profile configuration page contains a User name field which represents the profile user name and a

General section. This section contains: the user profile Password, the privilege level (specified in the Permission

field) and the two Local access and Remote access fields, where you can define some options that are associated

to the user profile, respectively for local access and remote access (from RICS client or Internet browser).

On this page you can modify a password, decide whether to display your user profile in the list together with the others

and whether to maintain the same user profile when the programme re-boots.

Moreover you can modify the attributes (user name, password, display in the list etc…) of the user profiles with a

privilege level that is less than your own, as well as being able to create new ones (still with a privilege level that is lower

than yours).

To select the various user profiles, you should use the Next and Previous buttons on the right. As already stated

RICS manages up to 12 user profiles.

12.2.2 Creation of a new user profile

To create a new user profile use an empty one or one which does not yet have a name.

You can only create user profiles with a privilege level lower than your own. To select the various user profiles, you

should use the Next and Previous buttons on the right. As already stated RICS manages up to 12 user profiles.

[ RICS ]Configuration of users profiles
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In the following table we show you the access privilege according to the level:

Level Access privilege

0 this is the level of the not logged user; it is not allowed changing the settings of the program or

develop report related to the recorded data. It is possible showing the device page and gaining

access (read only) to the information there are in the user interface defined by the software driver

of the instrument

1 and 2 the access privileges for these two levels are similar; level 2 the not available commands are shown

in grey, level 1 does not show these information at all. Level 2 allows showing all those functions

available at the above levels; level 1 has not this feature

3 and 4 the access privileges for these two levels are similar; according to the software driver of the

instrument, level 3 could not show information available at level 4 (internal values of the

instrument). Both the levels do not allow interacting on those settings about the hardware

(automatic reboot, backup, remote access, etc ...)

5 it allows interacting in all the settings of the program; it is possible gaining access to all the

internal values of the instrument (working setpoint, configuration parameters, devices status,

etc ...)

12.2.3 Properties of a local access user profile

For local access (Local access field, Screenshot 12) the following choices are available:

• Enable log in Local: by selecting this checkbox, the user profile is enabled for log-in. If the checkbox is not

selected, then even if the user profile exists, it is not recognised by RICS during identification.

• Visible in list: if this checkbox is enabled then the current user profile is included in the list of usernames

shown in the identification window (accessible from Main menu>Security>Log in)

• Keep on start: if this checkbox is enabled then if RICS re-boots with the user profile active, auto identification

ensues without asking the user for any information, so that the system starts-up with the user profile which it had

when it turned off.

12.2.4 Properties of a remote access user profile

In order to allow the use of a user profile for remote access, other settings must be made (Remote access field, Screenshot

12):

• Enable Remote access: by selecting this checkbox, the user profile is enabled for remote access. Remote

access via RICS Client software or via Internet browser cannot occur if this checkbox is not selected.

• Enable Web access: as well as the Enable Remote access checkbox, in order to allow access by browser

this option must also be selected. If the Enable Remote access checkbox is selected but not the Enable Web

access, the user can only gain access using RICS client software.

• Expiration date: this field specifies the date after which the profile will no longer be recognised as valid user

for remote access. Leave this field empty for unlimited access.

12.2.5 Special NOTLOGGED user profile

There is a special user profile, NOTLOGGED, with a privilege level of 0. This user profile is the pre-defined

profile is no identification procedure is followed.

12.2.6 Enabling the quick modification of the working setpoint through the Device inspector

Select the checkbox Allow easy setpoint modification to allow the working setpoint modification through the Device

inspector.

This option is available at level Installer or Administrator for the lower levels.

12.2.7 Enabling the access to configuration p arameters

Select the checkbox Allow Parameters to allow the access to configuration parameters.

12.2.8 Enabling the access to the internal values

To gain access to the internal values (Status, I/O, Info and Parameters) directly from the device (Examine>Internal

values), you must have at least permission 2.
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13 Information centre

To get to the window in Screenshot 13, go to Main menu>View>Information Central.

The Information Centre window allows the display of various pieces of information regarding the system communica-

tion services, such as for example e-mail, SMS Text Messages and fax.

For example you can see the time the last fax was sent, the time the next fax will be sent, and so on.

You can also check the status of the automatic data printout, check the time of the software re-boot and the next auto-

matic re-boot, as well as the time the system was last re-booted and the reception of the latest device data.

Screenshot 13: Information Centre window.

[ RICS ]Information centre
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14 Remote supervision

14.1 Introduction
There are various ways of gaining remote access to information managed by RICS:

• By Browser

• By Client/Server

• By Windows Remote Desktop of third-part packets.

It should be mentioned that display on a browser is often called “Web access” or “Internet Access” even if it can actually

be performed with a modem/modem connection, on a LAN or any other connection between two PCs with TCP/IP

protocol.

We will also use the terms “Web Access”, “Web pages”, etc to indicate access by browser, even when there is no real

Internet connection.

14.2 Access by browser
By RICS web we mean the ability to control a plant managed by RICS with normal internet browsers (such as Internet

Explorer, Firefox or Netscape). This allows an authorised user to access the system, controlling its status and maybe

changing some settings from any station with a web browser and without the need for specific software.

The server station can be accessed with a web browser thanks to a EVCOWebServer module that is copied onto the PC

during RICS installation (if you have chosen to install web extensions).

EVCOWebServer is an http server and as such remains in wait on a specific TCP port that can be configured by the user.

You can set this port during installation or with RICS already installed from Main

menu>Configure>General>Remote access>Web Manager>HTTP Port (see Screenshot 14).

Screenshot 14: Configure/General/Remote access/Web Manager window, highlighting the HTTP Port field.

[ RICS ]Remote supervision
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Normally the http service is connected to Port 80 but to avoid creating conflicts with other web servers that may

be installed on the operating system (e.g. IIS, Apache, etc… ), it is best to set this value to 8080 or 8081 and so

on.

Suppose you have set the HTTP Port to 8080. Also suppose that the server IP address is 145.163.21.19. To gain access to

the server from the client you should type http://145.163.21.19:8080 in the browser address line..

The server must have a static IP address to be accessible from the outside. If the server is on a LAN then the network

administrator may need to configure the router and firewall.

To gain access from a client PC (on a LAN) to a server (on the same LAN) just use the IP address or the name of the host

of the PC server that identifies it on the company network, respecting the guidelines shown above.

You can access RICS by browser from the local PC upon which RICS is running by typing the following text in the

browser address line: http://localhost:8080 (if the http Port is 8080, otherwise type the correct value; if the port is 80,

then you can omit “:80” and just type: http://localhost). On the local PC you can also gain access from Main

menu>View>Web access (see Screenshot 14.1).

Screenshot 14.1: Web access from the Local PC.

14.2.1 RICS Web Functions

When you access RICS from a browser, the first page that appears will contain a log-in form that identifies the user that

is attempting to gain access. The RICS web section can be accessed by all users who have selected the Enable

Remote access and Enable Web access checkboxes, in the user profile configuration page within RICS (see

Screenshot 12). When these checkboxes are selected it is a normal security precaution to change the password.

Moreover for improved security it is a good idea to change the user names of the pre-defined user profiles within

RICS during installation (for example users like ADMINISTRATOR or INSTALLER).

For Web RICS, too, the functions that can be accessed will vary depending on the privilege level of the user.

From the page with the log-in form you can also state whether the client that is being used to access the system is a

portable PC or not. If you select the Portable option on this page, the pages will be displayed with simple

graphics and some functions that may slow navigation will be inhibited. This function is useful in as much as it will

be possible to access a remote plant from some types of mobile phone.

Once authorised by the system you go to the main page (see Screenshot 14.1) that displays a table containing informa-

tion about all the devices on the plant (probe measurements, setpoint values, a short description of the device status,

etc… ). Essentially this page displays the global plant status.

On this page the name and number of each device represents a link that leads to a detailed page for the device itself.
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The device page (see Screenshot 14.2) contains the following information:

• Values measured by the probes

• Setpoint values

• Values of the main parameters

• Alarms that are now active or that have been active.

Screenshot 14.2: Device page in RICS web mode.

From the menu on the left-hand side of the screen in Screenshot 14.2 you can access:

• Device: for choose the device

• Parameters (which can be changed)

• Status:

• I/O: Input and output values

• Alarms: information about the alarms, with ability to manage them

• Data historian (tables, charts and the possibility of setting the time interval desired between one recording

and the next or to choose between pre-defined time intervals, i.e. short, medium, and long). Choose Data

historian>Excel to save the table in Excel format in the browser Personal Computer (Microsoft Excel must

be installed in the Server station).

• Events:

• Info (address, model, driver)

• Configure (name, recording interval).

Going back to the page containing the global plant status, on the left-hand menu you can access:

• The plant event-history (Events button)

• Plant administration page (Administration button), from which you can configure:

- General settings (station name, recording interval, etc…)

- Message Manager (e-mail, fax, SMS Text Messages)

- User profiles

- Alarm categories.

On each web-page that allows the modification of settings you must click on the Confirmation button (Enter, Write,

Submit, etc…) at the bottom of the form in order to apply those settings.

After navigation you must follow the log-off procedure by clicking on the link at the top of each page.

You can access the detailed device page with the device-navigator at the bottom of each section. You can choose

the name of the device, input its number or even use the navigation arrows.
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14.2.1.1 Page refresh

The refresh of information on each page is automatic depending on certain criteria. Normally information is refreshed

every 30 seconds – 1 minute, up to a maximum of 2 minutes when it is assumed that the data values do not change very

often.

Refresh cannot occur more frequently as this would make navigation very slow indeed, and may lead to the saturation of

slower connections.

If you want an immediate refresh, in some sections you can click on the refresh icon in the bottom-left corner under the

text that shows when the latest data was received (see Screenshots 14.1 and 14.2).

This consideration regarding refresh times must also be remembered when you change a device parameter, in so far as

the new value given will not be displayed on the screen immediately but only after the refresh of the page itself.

In the event of data input the web-pages use a technique that requests a more frequent refresh than that used during

simple navigation.

14.3 RICS Client/Server
RICS allows the supervision of a remote plant comprising EVCO devices with a particular configuration called RICS

client/server. In order to do this you will need a PC upon which RICS is installed as server and at least one PC where

RICS is installed as client.

RICS server is the software that directly manages the EVCO device network (i.e. reads data, saves it, manages any

messaging services such as e-mail, sms text messages, fax), with the configuration of a PC-IFC29 device network.

Moreover it can accept connections coming from RICS clients that can interact with the plant managed by the server

using an interface that is similar to that on the server itself. A client station can:

• Display the status of a remote plant

• Read/write parameters on any remote device

• Perform a file download of files in the remote system (settings, history, etc…) or transfer files from the client system

to the server (updates).

Client/server communication can occur on three different channels:

• Direct modem call: in this case there can be only one active client using this sort of communication; the client must

know the telephone number of the server (the RICS server operating system must be Windows XP Professional or

better)

• Via company network or LAN: in this case the server can be reached by the client using an IP address or the name of

the server host within the company network

• Via Internet: in this case the server can only be reached if it has a static IP address that identifies it in Internet.

In addition to this type of remote management that requires an RICS server and an RICS client, you can also access the

server with commercial software (such as PC Anywhere) or, with the Remote Desktop service in Windows if you have

Windows XP Professional on the server. As regards this latter service you are referred to Microsoft documentation for

further information. The software that must be installed on the client to use the Remote Desktop service can be downloaded

from: http://www. microsoft.com/Windowsxp/pro/downloads/rdclientdl.asp.
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14.4 Client/Server system structure
The RICS client/server system can be summarised in Screenshot 14.3.

Screenshot 14.3: Diagram showing RICS client/server connections

14.5 RICS Client
When RICS is installed as a client it allows the supervision of remote RICS stations. Once inside RICS (client), the

following operations are possible:

• Creation of a new connection for access to a remote RICS server (choose Server>New)

• Change the settings of an existing connection (after choosing it in the Remote Stations (Server) list, select

Server>Settings)

• Remove an existing connection (choose Server>Cancel)

• Begin a connection to a Remote RICS server (after choosing it in the Remote Stations (Server) list, select

Server>Connect)

• Browse the hard disk on the remote system, with the possibility of downloading a list of files on the server onto the

client PC. You can also do the reverse, transferring a list of files on the client PC to the server (go to

Server>Browse).

• End a current connection (choose Server>Disconnect)

• Produce off-line reports without being connected to the server. This can only be done if you have downloaded the

file containing the data history choose Server>Reports>New (or Open)).

14.5. 1 Creation of a connection to a remote server

When creating a connection to a remote server you must specify the following fields:

• Logical Name: this represents the logical name that shall be associated to the connection (for example this

could be the name of the server station). It must be unique – there cannot be two connections to distinct

servers with the same name.

Connection Page:

• Type: represents the type of connection which can be one of the following:

- Telephone call (RAS): the communication is made using a telephone line and modem. The type

of Windows remote connection to be used must be specified; the server must have Windows “Remote access”

enabled. Once the connection has been created the communication runs on a TCP/IP channel.

- Local Network (LAN): client and server are on the same company network. You must specify the server IP

address (e.g.: 192.168.55.21)
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- Internet: client and server use internet to communicate. The server must have a unique static IP address

which identifies it: this address must be specified in the Address field. The client must already have connected

to internet before connecting to the server, or RICS will connect with the internet provider using the

connection name specified in the General settings, Internet connection field (this can be accessed on

Main menu>Connection>Settings)

- Username and Password: these fields represent the username and password of a user profile on the RICS

server (e.g.: INSTALLER) on which the Enable Remote access checkbox was selected in RICS

Options Page:

• Behaviour: Defines the purpose of the connection to the server. There are two possible types of behaviour:

- Browse the remote system: once connected this displays an image of the remote station; it shows the

classic RICS interface upon which you can interact with the devices

- Only perform download: After the download of the specified files, the client disconnects from the remote

server (this option can be useful, for example, when you only want to download the data history and then

analyse it off-line).

• Download: the files to be downloaded are specified. Amongst the possible file types are the following:

- Configuration: RICS server station configuration file. You are advised to always download these files. The

first time you connect you must download these files.

- History: files containing system server data. To allow the download the item that allows the download of

general historical data must be selected (in Connection>Configure).

• Server directory name: name of the directory (folder) where server files and settings are saved (by default

this is the name in the Logical name field). Just like the logical name, this field, too, must be unique, and

no connections can exist to distinct servers that have the same directory. This would lead to conflicting data.

RICS client can show distinct images of several server stations (e.g. device images, wallpaper images etc… ).

It only makes sense to share the same directory with different servers if they represent a connection to the

same station. This can occur when, for example, the servers are split logically because the connection

methods used by clients to access the servers are different.

Advanced page: you are advised to modify the contents of this page ONLY if you are an expert user. This page

allows the modification of parameters for the following services:

• FTP: In FTP services you can specify the Port in which the RICS server offers those services (the default is

2121) and whether the FTP connection is passive or not. If the server is located on a company network

protected by a firewall it may be necessary to enable the passive mode and ensure that port 2121 in the

firewall has been enabled on the server side; if the connection fails, you are advised to set the port (both on

the client and server) to 21, ensuring that the firewall on the server side has enabled port 21 (you will also

have to disable any eventual Windows FTP Services that use those ports, or ensure that those services use a

different port number to avoid possible conflicts).

• EDCS: this represents the protocol implemented by RICS for client/server communication in a TCP channel.

You are advised to leave the port on the default settings, both on the client and the server, or more precisely

Port 2345; in this case, too, if it crosses a firewall, the firewall must enable that port.

14.5.2 Connection within a LAN: an example

This section shows how to ensure a client/server RICS connection when both systems are on PCs in the same company

network.

In the example the following assumptions have been made:

• SERVER:

- Is a PC on a company network

- The LAN IP address is:130.164.0.88.

• CLIENT:

- is a PC on the same company network

- the LAN IP address is: 130.164.0.124.
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The server

• When the operating system this is being used allows it (Windows 2000 or better), ensure that any eventual

Windows FTP services are disabled or that the port they use is different from that used by RICS (EDCS Port

and FTP Port). If you are not sure how to change the ports used by Windows services, you are advised to shut

them down. To shut down the Windows services go to Control panel>Administration tools>Computer

management and then choose Services and applications>Services. At this point shut down the FTP

publication services.

• RICS server must be running with the default settings, which are:

- EDCS Port = 2345

- FTP Port = 2121.

These settings can be checked on Settings>System.

• Ensure that a user profile has been created within RICS where Enable Remote access has been selected. In

this example we assume the creation of a user with user name remoteuser003 and password ricscs.

The client

Once RICS (client) has started we create a new connection with the following settings:

• Logical name: Example station

• Connection type: LAN

• Address: specify the server IP address which in the example is 130.164.0.88

• Select Automatic log-in, specifying the username remoteuser003 and password ricscs

• Select Browse Remote system in the Options page and choose the files to be downloaded in the Download

section. The setting must be one of these; you are advised not to download the History if the aim of the

connection is only to control the remote system and the analysis of data is unnecessary).

• Finally ensure that the EDCS and FTP ports defined in the Advanced page coincide with those set on the

server, or, as in the example, EDCS Port=2345 and FTP Port=2121

• Once the new server has been created, select it from the Remote stations (Server) list and begin the

connection.

14.5.3 Modem to modem connection: an example

This section gives an example of how to obtain a client/server RICS connection with a point-point modem connection.

In the example the following assumptions have been made:

• Server telephone number: 0258479458

• Client telephone number: 0689455517.

This type of connection can be shown in the following Screenshot (Screenshot 14.4):

Screenshot 14.4: Modem to modem connection diagram.

Note: the server cannot have more than one client connected at the same time with a direct modem connection.

The server

Minimum requirements to obtain this type of connection is that the PC operating system where RICS server is installed

is at least Windows XP Professional or better.

In our example we used Windows XP Professional (Italian version).

The PC has a suitably configured modem.

Necessary operations:

• Ensure that any eventual FTP Windows services are disabled or that the port they use is different to that used by

RICS (EDCS and FTP ports). If you are not sure how to change the ports used by Windows services, you are advised

to shut them down; to do this go to Control panel>Administration tools>Computer management

then Services and applications>Services and then shut down the FTP publication services.
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• Ensure that the Windows Routing and Remote access services are enabled like in the Screenshot below

(Screenshot 14.5). To enable these services, go to Control panel>Administration tools>Computer

management and choose Services and applications>Services.

Screenshot 14.5: Control of the start-up of the Routing and Remote access service.

• Create a user profile in Windows that has the same username and password of a user profile in RICS that is enabled

for remote access. This Windows user must have a password that cannot expire. To create user profiles in Windows,

go to Control Panel>Administration tools>Computer Management and then choose Local users and

groups>Users. Suppose you create a user with the username remoteuser003 and password ricscs.

• Create a “connection upon entry” from Windows. To this end, go to Control Panel>Network connections.

Then in Network operations choose Create new connection. At this point a series of windows will open

where other fundamental choices must be made (if one of these options should not appear click Next):

- Installation of an advanced connection

- Accept entry connections

- Select the peripheral to be used for input connections, or the modem that will be used for input connections

- Do not allow private virtual connections

- Select the user created in section 3, as in Screenshot 14.6:

Screenshot 14.6: User selection icon.

Click on the Settings button in the Call-back page, then select:

• Do no allow call-back, if you want the cost of the call to be paid by the client.

• Allow the caller to specify a call-back number, if you want the server to call the client once the latter

has connected; this means the cost of the call is borne by the server.

• In the TCP/IP protocol settings select the Automatically assign TCP/IP addresses using DHCP field.
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The client

The Client PC has a suitably configured modem.

Once RICS (client) has started, you create a new connection with the following settings:

• Logical name: Example station

• Type of connection: Telephone call (RAS)

• In the Settings box click on the New RAS button. This opens the classic windows wizard that allows the

creation of a remote access; during creation it will ask for the telephone number of the connection, which

must be set as the server’s number (in the example it is 0258479458) and the name for the connection (in the

example it is “Remote RICS Example”)

• In the Connection name box (in the Settings box), select the newly created remote connection or in this

case “Remote RICS Example”

• Select the Ask the server to call back checkbox if you want the server to bear the cost of the call (only

possible if the server allows call-back). If this checkbox is selected you should insert the client telephone

number (that in the example is 0689455517) in the Call-back number field, in the above mentioned

Advanced page. If the number is always the same then the Call-back number field can be omitted, while

you are invited to specify it in the General settings section, (in Main menu>Connection>Settings) in

the Default call-back number field.

• Select the Automatic log-in checkbox using the username remoteuser003 and typing ricscs for the

password.

• In the Options page choose Browse remote system and in the Download section choose the files that you

want to download (The setting must be one of these; you are advised not to download the History if the aim

of the connection is only to control the remote system and the analysis of data is unnecessary).

• Lastly, ensure that the EDCS and FTP ports in the Advanced page match those set on the server.

• Once the new server has been created, select it from the Remote stations (Server) list and begin the

connection.

14.5.4 Connection with Internet: an example

This section contains an example of how to obtain a client/server RICS connection using Internet as the communications

channel.

In the example the following assumptions are made:

• SERVER:

- is a PC on a company network

- The LAN IP address is: 130.164.0.88

- The company network has a firewall

- The company network IP address to Internet (external): 157.87.98.12.

• CLIENT:

- Is a PC on the company network (but not the same one!) the LAN IP address is: 165.64.17.24

- The company network is protected by a firewall

- The company network IP address to Internet (external): 182.114.55.78.

We suppose that the company network on which the RICS server is located has a structure like this one (see Screenshot

14.7):

Screenshot 14.7: Diagram of a company network structure.
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The server

As you can see the client cannot access the RICS server PC directly, but must pass through the router and the

company firewall before reaching it.

In order to allow the RICS server to be reachable from outside, perform the following actions:

• Ensure that eventual FTP Windows services in the RICS server PC are disabled or that the port they use is different

from the port used by RICS (EDCS and FTP). If you are not sure how to change the ports used by Windows services

toy are advised to shut-down those services. To this end go to Control

Panel>Administration>Management of Computer and select Services and applications>Services.

At this point stop the FTP publishing service.

• Configure the firewall so that it enables the TCP ports used by RICS, in this example it must enable:

• FTP Port = 21

• EDCS Port= 2345.

• Configure the router table so that TCP/IP packets destined to the TCP ports used by the RICS server are send to the

station that is running the RICS server. In this example the table would look like this:

Port Destination

21 130.164.0.88

2345 130.164.0.88

• WWEnsure that in the RICS server programme a user profile has been created with the Enable Remote

access checkbox selected. In this case you need to create a user profile with username remoteuser003 and

password ricscs.

The client

The Client PC has a suitably configured modem.

Once RICS (client) has started, you create a new connection with the following settings:

• Logical name: Example station

• Connection type: Internet

• Address: specify the server IP address. In our example this is 157.87.98.12

• Select the Automatic log-in checkbox, with user name remoteuser003 and password ricscs (same profile

as a user created and configured on the server for this purpose)

• In the Options page choose Browse remote system and in the Download section choose the files that you

want to download (The setting must be one of these; you are advised not to download the History if the aim

of the connection is only to control the remote system and the analysis of data is unnecessary).

• Finally ensure that the EDCS and FTP ports in the Advanced page coincide with the settings on the server.

In the example the setting is EDCS Port=2345 and FTP Port=21. In the FTP service, considering that the

communication is filtered by a firewall, you are advised to select Passive Mode.

• Once you have created the new server, choose it on the list of Remote stations (Server) list and begin the

connection.
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14.6 Browsing the Remote Hard disk
There are two situations in which the remote hard disk can be examined by a client station:

• The connection to the server is inactive

• The connection to the server is active.

In both cases to get to these functions from the main menu choose Server and then Browse.

In the first case, initially a connection to the server is activated and then a window appears that allows navigation inside

the hard disk, while in the second case the window appears immediately.

The remote hard-disk navigation interface is shown in Screenshot 14.8.

Screenshot 14.8: The remote hard-disk navigation interface.

As you can see, this screen is split into two main panels. The upper panel shows a view of the remote hard disk, while

below you can browse the local disk. The upper panel (called Remote) is in turn split into two lists:

• Remote disk

• List of files to be downloaded.

You can consult the remote hard disk with the Remote disk List. A double-left click on folders opens that folder

(the complete path needed to get to this folder is shown in the Remote folder list). To leave the folder that you

are in just double left-click on ‘..’, that allows you to go up one level at a time. When there are files that you want

to download (identified by the File type), just select them and add them to the list of files to download with the

Add button. To remove a file from the list of files to be downloaded, just select it and click on Remove. Once all

the desired files have been included in the list you can download with the Download button from remote

system. During the download a window is displayed that shows progress. The directory in which you can find the

downloaded files is that in the server profile, in the Server directory name field in the Options page on the

server settings window. The complete path of the file destination is:

$RICS\STATIONS\NOME_DIR_SERVER

where:

• $RICS is the RICS installation directory. The default is: c:\evco\rics3

• NOME_DIR_SERVER is the name given to the directory in the server profile.
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For example it can be, “c:\evco\rics3\stations\example station”.

In the lower panel (called Local), you can move through the local disk with the lists in the left-hand side on the

panel. If you want to transfer a given file to the remote hard disk, just select it in the menu on the left and add it

to the List of files to transfer with the Add button on the same panel. Once the list of files to be transferred is

complete, you can transfer the chosen files to the remote hard disk with the Transfer to the remote system

button.

You can choose the destination folder on the server from amongst:

• Current remote folder

• Default session folder.

If you choose the first option then the destination folder is that present in the Remote folder field in the

Remote Panel. If the current folder is above that where RICS has been installed or in a different path to that

where RICS was installed then the files will be saved in the default session folder.

The default folder for the session depends on the date and in the server is:

$ R I C S\STAT I O N S\C L I E NT _yyyy_m m_ddd

where:

• $RICS is the RICS installation directory. The default is: c:\evco\rics3

• CLIENT_yyyy_mm_dd is the name given to the default session directory (yyyy is the year, mm the month and dd

the day, for example: 2004_03_06).

For example it could be “c:\evco\rics3\stations\client_2004_03_06”, if the transfer occurred on the 6th March 2004.
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15 Updates

15.1 Introduction
The Advanced version and the Top one offer the possibility to get some software updates.

The benefits introduced by an update usually concern what follows:

• the introduction of new functionalities

• the improving of existing functionalities

• the correction of possible errors

• the introduction of drivers, to allow the integration of new instruments

• the extension of new functionalities.

To enjoy the updates you need an internet connection on the Personal Computer where RICS is installed.

15.2 How to execute the up date
Operate as follows:

1. Start RICS.

2. Choose Help>Check for upgrade; RICS will open a web page (through the preset browser) where it will be

possible to test the presence of possible updates for the RICS version in use.

The web page contains a chart with the following fields:

- Date: it is the date of the update

- File name: it is the name of the update

- Description: it is the description of the update

- Notes: they are the notes about the update; the main news introduced with the updated are related here

- Download: it contains the button that allows to download the file of the update; a further indication informs if

the update is New (valid) or Obsoleted (obsolete and incorporated in valid updates)

3. Choose Download: the download of the file will start; as soon as the download finishes, quit RICS.

4. Double click the file of the update: the guided installation of the update will start.

5. Start RICS again.

[ RICS ]Updates
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